Problem communicating to the TCM - Diesel Bombers

Go Back  Diesel Bombers > Dodge Cummins > 5.9 Liter CR Dodge Cummins 03-07
Problem communicating to the TCM >

Problem communicating to the TCM

5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Problem communicating to the TCM

Reply

 
 
 
  #1  
Old 10-27-2016, 01:21 AM
Reddog80's Avatar
Newbie
Thread Starter
Join Date: Oct 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem communicating to the TCM

Hi, I am new here. I have a 2003 dodge ram 3500 diesel, 5.9 cummins, 24 valve, with a 48 RE transmission. I had the transmission rebuilt last year with a stage 1 rebuild. I had to take it back due to shifting problems and random temp light on the trans, but the temp light does not stay on long. When they looked at it they said that they can't communicate with the TCM. My question is has anyone had/has this problem or possible troubleshooting things to due to figure out why? I think my ignition switch is going bad could that have anything to do with it? Thanks in advance for any advice.
 
Reply With Quote
  #2  
Old 10-27-2016, 02:33 AM
Diesel Fan
Join Date: Feb 2016
Location: Vancouver wa
Posts: 24
Thanked 0 Times in 0 Posts
Default

What are the ignition symptoms? My 03 haso some play in the ignition. Have to make sure it is in off position or the blower runs the battery down. Sucks when you are running late in the am.
 
Reply With Quote
  #3  
Old 10-27-2016, 02:44 AM
Reddog80's Avatar
Newbie
Thread Starter
Join Date: Oct 2016
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the key will not go back into the acc. position, and in the off position the blower will run without the key in.
 
Reply With Quote
  #4  
Old 10-27-2016, 10:16 AM
Diesel Fan
Join Date: Feb 2016
Location: Vancouver wa
Posts: 24
Thanked 0 Times in 0 Posts
Default

My ignition has Don that for years. I just half pull the key out and turn twards the on position. The Com issue my best guess would be to check every connection our trucks have a habit of plugs coming loose. After that cpu problems suck.
 
Reply With Quote
  #5  
Old 07-11-2018, 02:24 PM
Newbie
Join Date: Jul 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem

I bought a used 03 ram 3500 5.9l that had the trans replaced. Shortly after buying it, it would stall when turning then starting going into limp mode. I would run a code reader and did the key thing to get codes that way as well. The code from the dash was always the p0700 code. After taking it different shops and getting no more. I swapped the tcm out with the one from my 97 ram 1500. I have a bad tcm. Now I am looking to either my tcm repaired or replaced.
 
Reply With Quote

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.