Diesel In Distress - Support Ticket Need Help ? Broke Down Or in Urgent Need Of Assistance Post Here , Thread Will Be Priority and You have the ability to close your own thread when its fixed . If You Do Not Reply in 10 Days your thread will be closed as we will assume its fixed , You can Reopen YOUR Discussion Topic if you wish .

2nd GEN ENGINE SURGING 50-200 rpm

  #1  
Old 03-12-2019, 07:15 PM
BOOTLEG012500's Avatar
Diesel Fan
Thread Starter
Join Date: Jan 2019
Location: Boca Raton FL
Posts: 13
Received 0 Likes on 0 Posts
Default 2nd GEN ENGINE SURGING 50-200 rpm

Hey guys need some help diagnosing an issue! I have an 01 2500 Cummins with 88k on it and just recently I have been experiencing some motor surging it doesnít lag but surges at random between 50-200 rpm when itís at speed on the highway, sometimes while Iím accelerating but not stomping on the pedal to get up to speed. Itís mostly when Iím kind of light on the throttle or holding speed on the highway. The weird part is I can let off the pedal and then stomp on it and it revs up fine. My psi gauge never drops below 10 wot and it shows steady pressure when the surging happens. Iíve got about 3500 miles on a new fuel filter as well as an airtex lift pump mounted at the factory spot on the motor. I have a big line kit from the end of the lift pump to filter and to injection pump. I canít find any leaks or anything loose. Anybody got any ideas????? Iím at a loss and donít wanna burn up the injection pump.
 
  #2  
Old 04-03-2019, 08:18 AM
Diesel Fan
Join Date: Apr 2016
Posts: 48
Likes: 0
Received 0 Likes on 0 Posts
Default

Take the battery leads off and clean them and clean the battery posts. If this fixes it you are experiencing the lockup problem we run in to. Basically the ground picks up noise from the ALT and causes the TCM to do weird stuff. Let us know if this fixes it. You can also take that ground wire run it away from the ALT and wrap it in tin foil.
 
  #3  
Old 05-09-2019, 09:59 AM
Newbie
Join Date: Apr 2019
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

I know this post is a bit old, but the first thing I'd check is if the liftpump is maintaining at least 6psi pressure. My old '01 started surging at highway speeds twice on me in its life and both times it was the LP failing. The factory LP on mine first went out at about your milage, somewhere between 80K-90k miles. I assume you know about the common issue with the 2nd gen Cummins having the LP fail and then they take out the VP44 if left that way for too long.
If it is the LP don't put on another "stock" LP. If you don't want to do a full FASS or Airdog system, then at least do a FASS DDRP. I put one on mine after losing 3 of the stock type LP's, and never had another issue after that. The DDRP bolts up in the factory location and is easy to swap out. It does come with two springs for the ball valve, the weaker one is the one installed in it when you take it out of the box. There will be another one in the box that is a stiffer spring, put that one in and never look back. DDRP has a four year warranty vs. the one year warranty the factory style pumps have.
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.