Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Dodge Cummins > 5.9 Liter CR Dodge Cummins 03-07
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


My 2006 cummins is getting harder and harder to start. I have changed the fuel pressure sensor on the pump and filter more times than I can count I was getting the fuel delivery air code The shop here in town wants to chage my ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-08-2012, 04:39 PM
Newbie

   

Default 2006 hard to start

My 2006 cummins is getting harder and harder to start. I have changed the fuel pressure sensor on the pump and filter more times than I can count I was getting the fuel delivery air code The shop here in town wants to chage my injectors for about 3000 I was going to try putting the rail relief valve cap in and see if that helps any other ideas would be great dont realy have the money to replace injectors right now thanks Alex
Reply With Quote
  #2  
Old 11-10-2012, 06:55 PM
South Texas Goat's Avatar
Diesel Fan
Status: Left Lane

   

Default

Not enuf info
Reply With Quote
  #3  
Old 11-10-2012, 09:05 PM
Newbie

   

Default

My truck has 242000 miles on it the only thing that I have done to it is take the cat out. Today temp outside was 18 and it fired up within 10 seconds and most of the day it started well then tonight it acted like it was not going to start took about 1 min to get it to start cycled the key 3 times before it did and the truck had only been off for 45 min at the max and after the truck starts it runs fine other than giving me the fuel delivery air every once and a while. When my truck gets the code it runs like crap if i try to accelerate to fast but if I just maintain the speed it runs fine and it has killed the truck once when it did it all I have to do is clear the code and it runs fine.
Reply With Quote
  #4  
Old 11-10-2012, 09:26 PM
South Texas Goat's Avatar
Diesel Fan
Status: Left Lane

   

Default

Mine. Never gave me starting problems, but all the other symptons I had, it would start run fine then run like crap and die, idling or driving. Reset my programer and take off. Lift pump , 3 days with the new one and no more problems. I got 204000 on mine. Might presure test it, mine was fluctuating a lot because the barbed fitting on the pump was cracked.
Reply With Quote
  #5  
Old 12-09-2012, 12:40 PM
Newbie

   

Default

Update on my truck changed battries out month ago after that the truck was starting alot better now the truck wont start with out hitting with either all it takes is a tiny bit after it starts runs fine down the road and I started having my tranny do wierd shifting at low speeds cant deside if it wants to shift or stay in lower gear and sometimes it takes a while for it to shift only at lower speed on take off it jumps back and forth I did drop the tranny pan and change the filter and trans fluid no metal in bottom of pan but id did smell burnt just about ready to give up on the truck any help would be great thanks Alex

Last edited by Derbygod; 12-09-2012 at 12:41 PM.. Reason: spelling
Reply With Quote
  #6  
Old 12-09-2012, 08:25 PM
South Texas Goat's Avatar
Diesel Fan
Status: Left Lane

   

Default

Well that is a bad habbit to start a diesel. It will want it everytime once you start it on that crack. I don't know how many miles got on it but if you have any kind of waranty left I would get it to Dodge, trany needs to be checked out, have checked your 'new' batteries? Maybe got a bad one, one bad cell could draw down both and give all sorts of low voltage problems.
Reply With Quote
  #7  
Old 12-10-2012, 08:37 AM
cerberus60's Avatar
Diesel Wrench

   

Default

If you are having to use ether to start it a good bet is the injectors are bypassing too much fuel at crank time. A return flow test will tell you if that is true.

Your shifting problem is typical when the gov pressure transducer and solenoid start failing. It almost always happens after a fluid change also. The OE pieces are good for about 40k then you might as well toss them with the fluid change. There ar ebetter p[ieces for this problem. Call Suncoast and order a GM solenoid replacement kit and a transducer from them.


If your fluid is burnt you may have other issues developing or just a lack of maintenance. You need to change the fluid every 30k or problems will ensue.

cerberus60's Sig:05 3500 QC SRW LWB 4x4, Smarty REVO, ISSPRO Gauges, 48RE, OPIE Inpu,t Billet Single Disk TC, Transgo Kit, other tweaks and parts

92 D250, 370 Marine Inj tips, Tweaked pump, HX35 60\16, 47RH, Billet TC, Transgo Kit
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 02:44 PM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check