E4od problem trans guys please help - Diesel Bombers

Go Back  Diesel Bombers > Ford Powerstroke > Ford Powerstroke 94-98 7.3L
E4od problem trans guys please help >

E4od problem trans guys please help

Ford Powerstroke 94-98 7.3L Discussion of 94-98 7.3 Liter Ford Powerstroke Turbo Diesels

E4od problem trans guys please help

Reply

 
 
 
  #1  
Old 10-31-2014, 07:44 PM
Newbie
Thread Starter
Join Date: Oct 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default E4od problem trans guys please help

I have a 10/94 powerstroke with an e4od. I bought the truck needing a transmission for 1000 bucks. I when I bought it it was starting out in high gear with no reverse. It also had the wires cut in the shift lever so I purchased a new one from the local ford dealer.. I had the trans rebuilt about a month ago, and when I got the truck back it was doing the same thing. I but even when I shifted it into first it wouldn't start out in first. So I was upset with the workmanship and took it to a much more reputable trans shop. After they rebuilt it, they had the same issue with the trans. So they went through all of the wiring and found a few of the wires going from the ECM to the mlps that didn't have continuity. Those wires were repaired and the mlps checked out.. He said that all of the wires read as they should and were able to shift the trans by grounding the solenoid pack. So he is sure hydraulically the trans is sound and the ECM was suspect. So after a ton of searching, he found me a reman ECM online. It was installed and still the same issue occurs. Starting out in high gear. So I called ford and they said the ECM needed to be flashed to factory programming. That was done today, and I received that call I've been waiting on for 2 months... Only to be served more bad news.... Same problem...... I am at a loss here and this is my only mode of transportation with 4 wheels and heat... Harley season has been over for about 2 weeks and that is my only mode of transportation until this truck is fixed.. If someone could ease help me on this... Maybe if something was over looked... Any thing would help at this point no one has ever "seen this problem" thanks

Jake
 
Reply With Quote
  #2  
Old 11-01-2014, 05:43 PM
Newbie
Thread Starter
Join Date: Oct 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Bump for an answer?
 
Reply With Quote
  #3  
Old 11-02-2014, 07:27 AM
Haveastroke's Avatar
Diesel Fan
Join Date: Jan 2012
Posts: 50
Thanked 1 Time in 1 Post
Default

There is no fix! I've been trying to fix mine for 2 year's now and nobody knows how to fix issues with shifting problems!
 
Reply With Quote
  #4  
Old 11-02-2014, 08:49 AM
Haveastroke's Avatar
Diesel Fan
Join Date: Jan 2012
Posts: 50
Thanked 1 Time in 1 Post
Default

Mine will shift late and hard as hell, jump in and out of gear, lock and unlock the converter at random, lock the converter in reverse at random times, sometimes it does one of these things once and not again the rest of the day, then it does all of this stuff all day, some days it works great. I've changed fluid filter, vss and pigtail, fluid in the diff, cleaned and dialectic greased all connections at the trans. The speedometer doesn't jump erratic. It maybe moves 3mph at 70? Could it be the psom?
 
Reply With Quote
  #5  
Old 11-02-2014, 04:14 PM
Haveastroke's Avatar
Diesel Fan
Join Date: Jan 2012
Posts: 50
Thanked 1 Time in 1 Post
Default

Swapped a psom out of another cluster a friend had as spare parts. Then my speedometer didn't work but odometer worked and speedometer powered up off the needle. Then I swapped the spare speedometer and psom together in, same result. So I reinstalled my stuff and test drove and it shifted fine 1-2, 2-3, hard as hell 3-od but flashing light. Gonna try again after it cools off as I suspect it may be because it was warmed up (half the time symptoms would go away after I drive it 15 miles).
 
Reply With Quote
  #6  
Old 11-02-2014, 06:37 PM
Newbie
Thread Starter
Join Date: Oct 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by Haveastroke View Post
There is no fix! I've been trying to fix mine for 2 year's now and nobody knows how to fix issues with shifting problems!
HaveAstroke, I can understand the frustration.. I really do, but these trucks are machines and machines can be fixed. But diagnosing the true cause if the issue is the hard part. My truck does bone of the things that your truck does, but I'm sure we will get to the bottom of both our issues. As far as I am concerned we just need to find the right person with the know how to diag, and fix the issue
 
Reply With Quote
  #7  
Old 07-08-2015, 07:08 AM
Haveastroke's Avatar
Diesel Fan
Join Date: Jan 2012
Posts: 50
Thanked 1 Time in 1 Post
Default

Originally Posted by Jake9473 View Post
HaveAstroke, I can understand the frustration.. I really do, but these trucks are machines and machines can be fixed. But diagnosing the true cause if the issue is the hard part. My truck does bone of the things that your truck does, but I'm sure we will get to the bottom of both our issues. As far as I am concerned we just need to find the right person with the know how to diag, and fix the issue
Did you get it fixed?
 
Reply With Quote
  #8  
Old 07-22-2018, 08:19 AM
Newbie
Join Date: Jul 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Had a very simular issue with my 96 f150 with a 300. Took it to 3 or 4 shops and they kept telling me the trans needed to be rebuilt. Ended up replacing park neutral safety switch and every now and then it would act fine but problem was still there. Speedo was jumping around all over the place and making transmission go gear to gear and act crazy and ended up pulling speed sensor out of rearend and it was covered in metal shavings from pinion gear bearings could clean it and truck would run perfect for about 3 miles and go back to the craziness. Rebuilt rearend and replaced speed sensor and had no issues from it for the 30,000 more miles i put on it while i had it. Hope this helps someone
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
burndiesel
24 Valve 2nd Gen Dodge Cummins 98.5-02
9
12-14-2015 02:31 PM
jeremy01995
12 Valve 2nd Gen Dodge Cummins 94-98
1
09-14-2015 06:34 PM
dc2188
Chevy/GMC Truck and Duramax Turbo Diesel Forum
0
09-05-2015 10:41 AM
Rabbitjbu
Ford Powerstroke 94-98 7.3L
1
07-28-2015 06:03 PM
Pyrohigh
5.9 Liter CR Dodge Cummins 03-07
2
10-11-2014 07:59 AM


Thread Tools
Search this Thread