oil pressure or coolent sensor? - Diesel Bombers



Ford 83-94 6.9 and 7.3L General Discussion of 83-94 6.9 and 7.3 Liter Ford Diesels

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-14-2010, 08:34 PM
Diesel Enthusiast
Thread Starter
 
Join Date: Sep 2009
Location: buffalo ny
Posts: 177
Default oil pressure or coolent sensor?

any one have any idea where the oil pressure sensor is on the 7.3? and also where is the coolent temp sensor? both i think are shot any way to test these things? thanks tim
Reply With Quote
  #2  
Old 12-14-2010, 09:02 PM
Diesel Bomber
 
Join Date: Sep 2009
Posts: 2,492
Default






they are cheap. just replace them if u suspect them to be bad. but fyi, the stock gauges suck. get a good set of aftermarket gauges.
Reply With Quote
  #3  
Old 12-15-2010, 07:47 AM
Diesel Fan
 
Join Date: Oct 2010
Location: Florida
Posts: 22
Default

My oil gauge moves to high when you turn on the ignition on then drops off the low side as soon as you crank and stays there, have good oil press hooked up test gauge could this be the sensor bad and is that the one on my turbo???????
Reply With Quote
  #4  
Old 12-15-2010, 09:53 AM
Diesel Bomber
 
Join Date: Sep 2009
Posts: 2,492
Default

yes, the sender should be on the top of the turbo if u have the factory turbo setup.

like i said. senders are cheap. u can take it out and replace it quickly, but could also be the gauge itself. the factory "normal" gauge doesnt mean crap. just because it is at the "n" doesnt mean u have low pressure. just crap gauges. same with temp and voltage.
Reply With Quote
  #5  
Old 12-15-2010, 05:25 PM
Diesel Fan
 
Join Date: Oct 2010
Location: Florida
Posts: 22
Default

So you suggest replacing all three with aftermarket. Any brand???? also would like to get a pyro gauge I see you guys talking about them all the time. Can you suggest where I can get a good set. Thanks
Reply With Quote
  #6  
Old 12-15-2010, 06:35 PM
Diesel Bomber
 
Join Date: Sep 2009
Posts: 2,492
Default

autometer, isspro ect. place a request on this site up in the request a qoute forum.

dont need voltage gauge, but a good oil pressure and engine temp is needed.
Reply With Quote
  #7  
Old 12-17-2010, 08:09 AM
Diesel Fan
 
Join Date: Oct 2010
Location: Florida
Posts: 22
Default

Thanks DC
Reply With Quote
  #8  
Old 12-17-2010, 11:26 PM
Diesel Enthusiast
Thread Starter
 
Join Date: Sep 2009
Location: buffalo ny
Posts: 177
Default

so the engine temp is acutally on the side of the ip pump?
Reply With Quote
  #9  
Old 12-18-2010, 12:56 AM
Diesel Bomber
 
Join Date: Sep 2009
Posts: 2,492
Default

no, that is the cold advance and the high idle solinoid.

temp senders are on driverside head. there are 2. one controls the gauge, the other the engine overheat lamp.
Reply With Quote
  #10  
Old 12-18-2010, 01:06 AM
Diesel Enthusiast
Thread Starter
 
Join Date: Sep 2009
Location: buffalo ny
Posts: 177
Default

any idea ewhich controls which cuz the guage dont work neither does the oil, spedo or the fuel level... maybe the cluster?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2005 cummins losing oil pressure HELP Durtyd09 5.9 Liter CR Dodge Cummins 03-07 3 11-11-2015 01:43 PM
Exhaust Emission Info DEF/SCR/DPF Jet A Fuel 6.7 Liter Dodge Cummins 2013+ 8 10-21-2015 03:30 PM
Exhaust Emission Info DEF/SCR/DPF 2007.5 Jet A Fuel 6.7 Liter Dodge Cummins 07.5-12 3 08-03-2015 10:45 AM
TROUBLE CODE P1755 ? robbyS 5.9 Liter CR Dodge Cummins 03-07 3 04-16-2015 02:22 PM
low oil pressure at idle jhprice Ford Powerstroke 03-07 6.0L 5 03-29-2015 09:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:22 AM.