NEWBIE!!! LOSS OF POWER WHEN I STICK MY FOOT IN IT!! - Diesel Bombers



5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-09-2012, 02:02 AM
Newbie
Thread Starter
 
Join Date: Aug 2012
Location: CENTRAL. CA
Posts: 9
Default NEWBIE!!! LOSS OF POWER WHEN I STICK MY FOOT IN IT!!

FIRST TIMER HERE AND BEEN READING FOR THE LAST FEW WEEKS AND TRYING DIFFERENT STUFF THAT IVE READ ABOUT....

2005 DODGE DIESEL 5.9 CUMMINGS........ STARTS GREAT RUNS GREAT BUT WHEN I STICK MY FOOT IN IT TO PASS OR ACCELERATE IT BOGGS .......RUNS FINE UNTIL IT HITS ABOUT (2000 - 2300) RPMS THEN CUTS OUT TILL I LET MY FOOT OFF THE GAS........NO BUCKING OR JUMPING JUST ACTS LIKE ITS KICKING IT INTO LIMP MODE OR STARVING FOR GAS......

THE THING THAT IS GETTING ME IS IM GETTING NO CODES ANY WHERE....... HOOKED IT UP TO A SCANNER AND NOTHING..... EVEN WITH THE TURNING THE KEY ON AND OFF THREE TIME TRICK I STILL GET NOTHING......NO CODES........

ALWAYS HAVE CHANGED MY FUEL FILTER WHEN I CHANGE THE OIL.... BUT JUST PUT A NEW ONE IN JUST TO TRY..... CHECKED ALL MY BATTERIES THINKING I MAY BE HAVING A BAD GROUND ISSUE SAW NOTHING THERE.......

JUST ORDERED A NEW FCA..(FUEL CONTROL ACCTUATER) HOPING THAT MAY BE THE PROBLEM....... NEXT I GUESS WILL BE THE LIFT PUMP??????......BUT I HATE TO HAVE TO DIG INTO THE TANK TO MESS WITH IT...... BUT I WILL IF I HAVE TO......


ANY HELP WILL BE GREAT.......

HELL I EVEN THROW IN A GUIDED BASS FISHING TRIP TO THE CA DELTA IF SOME ONE CAN HELP FIX ER UP.......
Reply With Quote
  #2  
Old 08-09-2012, 08:16 AM
dangerous1965's Avatar
Diesel Bomber
 
Join Date: Dec 2008
Location: Escondido CA
Posts: 1,706
Default

First get a gauge hooked up to the delivery line to the CP3 that will tell you fuel pressure
at full throttle. A rail pressure gauge would really help!! Next unplug your FCA for a few seconds what did it do? Can't wait to go fishing!
Reply With Quote
  #3  
Old 09-01-2012, 09:20 PM
12 valve and proud's Avatar
Diesel Bomber
 
Join Date: Jun 2012
Posts: 2,122
Default

Have you adjusted your front transmission band?
Reply With Quote
  #4  
Old 09-04-2012, 05:05 PM
Newbie
Thread Starter
 
Join Date: Aug 2012
Location: CENTRAL. CA
Posts: 9
Default

OK IM BACK...... AND YES I HAVE ADJUSTED THE FRONT BAND ON MY TRANNY......

I INSTALLED A NEW AIR DOG SYSTEM..... BUT STILL NO CHANGE.....

I HAVE GOOD FUEL PRESSURE AT THE RAIL AND ON THE LOW PRESSURE SIDE......

NEW (FCA)..... STILL NO CHANGE....STILL NO CODES

STILL DRIVES JUST FINE.... STARTS FINE..... IDLES FINE...... BUT AFTER I STICK MY FOOT IN IT WITH IT IN GEAR....ONCE IT GETS UP THERE IN THE RPMS IT BOGS OUT.... CUTS OUT..... LIMP MODE IS KICKED IN...... STILL DONT KNOW.....

ORDERED A TUNER/PROGRAMER SO I CAN SEE A LITTLE BETTER AS TO WHAT ELSE MIGHT BE GOIN ON.........

ANY IDEAS.........ONE THING IM NOT SEEING WHEN I TRY TO ROMP ON IT IS BLACK SMOKE LIKE NORMALLY...... HOW DO YOU CHECK YOUR TURBO..... EVEN TRYING TO POWER JACK IT IN MY DRIVE WAY NOT GETTING ANY EXAUST SMOKE.....

WHY NO CODES.......L;OLOLOLOL..... GOTTA BE SOMTHING SIMPLE RIGHT...???

LOVE WORKIN ON MY TRUCK BUT THIS IS GETTIN OLD!!!!!!.......
Reply With Quote
  #5  
Old 09-04-2012, 10:30 PM
dangerous1965's Avatar
Diesel Bomber
 
Join Date: Dec 2008
Location: Escondido CA
Posts: 1,706
Default

No codes with Limp mode on? HMMM Going to have to wait for more info when you get your tuner. Something is not reading right causing the engine to protect itself It's either air or fuel!
Reply With Quote
  #6  
Old 09-04-2012, 11:06 PM
Diesel Fan
 
Join Date: Aug 2012
Posts: 15
Default

check your intercooler, some 2005's had plastic tank intercoolers that are known to blow out, i recently had to replace one in a friends 05
Reply With Quote
  #7  
Old 09-05-2012, 10:01 PM
CHEMMINS's Avatar
Diesel Enthusiast
 
Join Date: Nov 2007
Location: Alberta
Posts: 293
Default

Check the throttle position sensor.
Reply With Quote
  #8  
Old 09-05-2012, 10:08 PM
12 valve and proud's Avatar
Diesel Bomber
 
Join Date: Jun 2012
Posts: 2,122
Default

Check your tranny and exhaust sensors

X2 on checking the TPS
Reply With Quote
  #9  
Old 09-10-2012, 10:24 PM
Newbie
Thread Starter
 
Join Date: Aug 2012
Location: CENTRAL. CA
Posts: 9
Default

OK GOT A NEW...TPS.... STILL DIDENT WORK

..... GOT THE SMARTY HOOKED UP AND SAYS IM LOOSING BOOST WHEN I ROMP ON IT...... BOOST LEVEL IS JUST FINE CRUSING AROUND BUT WHEN I ROMP ON IT THE READING DROPS DOWN TO NEAR NOTHIN........

TURBO GOING BAD???
WASTE GATE STUCK ????
INTER COOLER BLOCKAGE?????


ANY IDEAS.....

ALL THE OTHER GAUGES AND READINGS ARE LOOKING NORMAL
Reply With Quote
  #10  
Old 09-10-2012, 10:34 PM
1999stroker's Avatar
Diesel Bomber
 
Join Date: Jun 2011
Location: Squaller holler, ohi
Posts: 3,369
Default

Check your shaft play. Also check for boost leaks.

Sent from my DROID BIONIC
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2002-2007 Ford F350 Super Duty Truck Power Heated Signal & Clearance Light Textured B 1ATony 1A Auto Parts 1 12-07-2015 01:09 PM
1999-2007 Ford F250 Super Duty Truck Power Textured Black Dual Arm Power - Folding To 1ATony 1A Auto Parts 1 10-29-2015 02:11 PM
P2552 trouble code and slight power loss after EGR delete and oil cooler replacement Bighouse Ford Powerstroke 03-07 6.0L 1 04-09-2015 06:51 PM
1997 chevy 6.5 liter k3500 loss power steering when i letoff throttle krg3590 Chevy/GMC 6.2L and 6.5L 3 03-15-2015 08:57 AM
2000 7.3 random vibration no loss of power needmore Ford Powerstroke 99-03 7.3L 4 12-02-2014 03:08 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 07:37 AM.