1999 7.3 no wts no glow plugs working - Diesel Bombers



Ford Powerstroke 99-03 7.3L Discussion of 99-03 7.3 Liter Ford Powerstroke Turbo Diesels

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-25-2011, 12:38 PM
Newbie
Thread Starter
 
Join Date: Oct 2011
Posts: 3
Default 1999 7.3 no wts no glow plugs working

all fuses good changed gpr put used pcm in it nothing helped. any ideas would be appreciated
Reply With Quote
  #2  
Old 10-25-2011, 02:59 PM
Diesel Enthusiast
 
Join Date: Oct 2009
Location: braintree ma
Posts: 242
Default

Welcome,how do you know their not working? Is the wait light not working?
Reply With Quote
  #3  
Old 10-25-2011, 03:41 PM
Newbie
Thread Starter
 
Join Date: Oct 2011
Posts: 3
Default

wts doesnt work cant hear the cycle also have no voltage to fuel pump could it be idm
Reply With Quote
  #4  
Old 10-25-2011, 05:00 PM
95powersmoker's Avatar
BOMBARDIER
 
Join Date: Mar 2010
Location: Ellensburg, WA
Posts: 2,959
Default

Check your fuses... I bet the fuel bowl heater shorted out and blew that fuse which also controls PCM...
Reply With Quote
  #5  
Old 10-25-2011, 06:11 PM
Newbie
Thread Starter
 
Join Date: Oct 2011
Posts: 3
Default

all fuses are good
Reply With Quote
  #6  
Old 10-25-2011, 07:02 PM
95powersmoker's Avatar
BOMBARDIER
 
Join Date: Mar 2010
Location: Ellensburg, WA
Posts: 2,959
Default

Quote:
Originally Posted by hoss74 View Post
all fuses are good
double check them... Don't just look at them and say ah ya it's good. I've seen bad fuses look ok... Underhood fuses too...
Reply With Quote
  #7  
Old 10-25-2011, 07:17 PM
fordornothing's Avatar
Diesel Bomber
 
Join Date: Jul 2010
Location: Hays, KS
Posts: 3,884
Default

ren a continuity test on them...
Reply With Quote
  #8  
Old 10-25-2011, 07:24 PM
95powersmoker's Avatar
BOMBARDIER
 
Join Date: Mar 2010
Location: Ellensburg, WA
Posts: 2,959
Default

Check Fuse #30 under the dash... That's where my money is at...

Also unplug the fuel bowl heater...
Reply With Quote
  #9  
Old 10-26-2011, 08:11 PM
Diesel Enthusiast
 
Join Date: Apr 2011
Location: Waynesboro,PA
Posts: 268
Default

my 95 did this years ago heading to the races, it was a big fuse under the hood. fuel heater element i believe is what it was called. dam thing kept blowing fuses when i'd turn the ignition on. dang, that was expensive til i figured out what wire to unplug so i could get to the dang racetrack!!!
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
7.3 idi glow plug problems/Question Metz1234 Ford 83-94 6.9 and 7.3L General 3 03-03-2016 10:20 PM
glow plugs rkp209 Chevy/GMC Duramax 2011 LML 1 01-10-2016 10:32 AM
7.3 IDI Glow plugs won't come out Toms73 Diesel In Distress - Support Ticket 1 03-23-2015 08:31 PM
92 7.3 idi glow plug relay no power Texasthb Ford 83-94 6.9 and 7.3L General 1 03-04-2015 08:20 AM
No WTS light, no start, 91 7.3 diesel Baconjosh Ford 83-94 6.9 and 7.3L General 8 12-11-2014 03:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:50 PM.