icp sensor???? - Diesel Bombers



Ford Powerstroke 99-03 7.3L Discussion of 99-03 7.3 Liter Ford Powerstroke Turbo Diesels

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-01-2011, 12:08 AM
Bigred7.3's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Aug 2010
Location: Davie, fl
Posts: 392
Default icp sensor????

i changed the icp sensor the other day and my truck still runs the same it did b4, but my question is the truck runs the same if the icp is pluged in or not so whats its purpose?
Reply With Quote
  #2  
Old 04-01-2011, 12:16 AM
95powersmoker's Avatar
BOMBARDIER
 
Join Date: Mar 2010
Location: Ellensburg, WA
Posts: 2,959
Default

If it runs the same unplugged as with it plugged, it is doing its job... If you have a bad sensor and unplug it, it should run better because it will default back to factory set parameters...

It's purpose it to read HPO pressure going to the injectors.
Reply With Quote
The Following User Says Thank You to 95powersmoker For This Useful Post:
  #3  
Old 04-01-2011, 12:39 AM
Bigred7.3's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Aug 2010
Location: Davie, fl
Posts: 392
Default

o ok i gotya, thanks, i was gettin mad cuz that lil f**ker is wasnt cheap.
Reply With Quote
  #4  
Old 04-01-2011, 10:02 AM
Sponsor
 
Join Date: May 2010
Posts: 327
Default

Quote:
Originally Posted by 95powersmoker View Post
If it runs the same unplugged as with it plugged, it is doing its job...
Actually, that's not true.

If it runs the same while unplugged, then that means that the truck is already running on the "default" IPR mapping.

At idle on stock tuning, there should be about 540 or so PSI of injection pressure. Pressure should rise smoothly depending on load. Default values due to a bad sensor or wiring harness will put the idle PSI at about 725 and you will DEFINITELY hear a difference in the way the truck sounds at idle. Also, the ICP will NOT rise smoothly with load.
Reply With Quote
  #5  
Old 04-05-2011, 05:29 AM
Bigred7.3's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Aug 2010
Location: Davie, fl
Posts: 392
Default

alright so how do i kno if its working or not? and the truck still has a miss even after new injectors and new cam shaft sensor.

---AutoMerged DoublePost---

alright well today my truck threw a code, p1211, i looked it up on and that code is P1211 ICP Not Controllable - Pressure Abow/Below Desired..... so apparently the damn thing isnt fcking working and its brand new, what do i do to fix this

Last edited by Bigred7.3; 04-05-2011 at 05:29 AM. Reason: Automerged Doublepost
Reply With Quote
  #6  
Old 04-05-2011, 10:23 AM
95powersmoker's Avatar
BOMBARDIER
 
Join Date: Mar 2010
Location: Ellensburg, WA
Posts: 2,959
Default

Quote:
Originally Posted by Bigred7.3 View Post
alright so how do i kno if its working or not? and the truck still has a miss even after new injectors and new cam shaft sensor.

---AutoMerged DoublePost---

alright well today my truck threw a code, p1211, i looked it up on and that code is P1211 ICP Not Controllable - Pressure Abow/Below Desired..... so apparently the damn thing isnt fcking working and its brand new, what do i do to fix this
Did the CEL come on at WOT? Did it come on at idle? More details about the code.
Reply With Quote
  #7  
Old 04-05-2011, 11:52 AM
Bigred7.3's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Aug 2010
Location: Davie, fl
Posts: 392
Default

i dont kno when it came on. ive got a superchip programer and its got the dtc reader in it and every now and then ill plug it in to see if there are any new codes that come up and last night that code showed up, so i looked it up on the fourm here and thats what it says it is "ICP Not Controllable - Pressure Abow/Below Desired"
Reply With Quote
  #8  
Old 04-05-2011, 12:48 PM
95powersmoker's Avatar
BOMBARDIER
 
Join Date: Mar 2010
Location: Ellensburg, WA
Posts: 2,959
Default

Reset it and don't worry about it for now. I can get that code running in my extreme tune at WOT...
Reply With Quote
  #9  
Old 04-10-2011, 02:34 AM
Bigred7.3's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Aug 2010
Location: Davie, fl
Posts: 392
Default

i reset the code, and the truck was fine (still has a miss tho) but yesterday i went to drive the truck after it only sat for 3 or so hours and it started with a loping idol, it leveled out after a few seconds but it ran lis complete dog sh*t.... i shut it off and read the codes and it threw the p1211 code again, so i cleared it and started the truck bac up with no lope idol but it still ran bad so i read the codes again and the p1211 code was bac i cleared it once more and has been ok sice. why does it keep doing that
Reply With Quote
  #10  
Old 04-27-2011, 04:53 PM
RattleBomb7.3's Avatar
Diesel Enthusiast
 
Join Date: Oct 2010
Location: Colorado
Posts: 148
Default

wish I could help you out, i'm having the same problem!!! is it inconsistently running bad??

Last edited by CSIPSD; 04-27-2011 at 05:03 PM. Reason: Watch the language please...
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Exhaust Emission Info DEF/SCR/DPF Jet A Fuel 6.7 Liter Dodge Cummins 2013+ 8 10-21-2015 04:30 PM
2003 6.0 powerstroke high/false icp Svonasek Ford Powerstroke 03-07 6.0L 1 10-08-2015 11:25 AM
Exhaust Emission Info DEF/SCR/DPF 2007.5 Jet A Fuel 6.7 Liter Dodge Cummins 07.5-12 3 08-03-2015 11:45 AM
HELP crank sensor or pcm? Mr. Walkway 12 Valve 2nd Gen Dodge Cummins 94-98 3 05-11-2015 11:49 AM
TROUBLE CODE P1755 ? robbyS 5.9 Liter CR Dodge Cummins 03-07 3 04-16-2015 03:22 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:21 AM.