new glow plugs, wont start - Diesel Bombers



Ford Powerstroke 99-03 7.3L Discussion of 99-03 7.3 Liter Ford Powerstroke Turbo Diesels

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-10-2010, 03:02 PM
99stackedpowerstroke's Avatar
Diesel Wrench
Thread Starter
 
Join Date: Dec 2009
Location: southeast Iowa
Posts: 687
Default new glow plugs, wont start

i put new glow plugs in last night, i put a new glow plug relay on, truck still wont start if it drops below 40ish, it blows white smoke so i know its cranking good and pushing fuel through the system, what should i check for? it did this before that's why i changed everything but it didn't change anything, if i plug it in and get it started, it will start perfect the rest of the day

---AutoMerged DoublePost---

i tested glow plug relay, with key off i have power to one big stud(the power side) and with the key on i have power on the power side of relay and one small stud (the front stud), this accurate? i haven't tested it while its cranking over yet, do i need to? there is no power to the second big stud or the small stud towards the back of the motor,

Last edited by 99stackedpowerstroke; 12-10-2010 at 03:02 PM. Reason: Automerged Doublepost
Reply With Quote
  #2  
Old 12-10-2010, 03:23 PM
CSIPSD's Avatar
Diesel Bomber
 
Join Date: Sep 2007
Location: Bend OR
Posts: 7,639
Default

Did you replace the correct relay? Are you testing the correct relay?

There are two there... One for the intake air heater, and one for the glow plugs.
Reply With Quote
  #3  
Old 12-10-2010, 09:13 PM
99stackedpowerstroke's Avatar
Diesel Wrench
Thread Starter
 
Join Date: Dec 2009
Location: southeast Iowa
Posts: 687
Default

not on mine i only have on top of motor, and it was a bad relay from the start, i jumped the relay, and i heard my glow plugs kick on, so i jumped it for 10 seconds and it fired right up, so i replaced it and now it works perfect and i have power to the other big stud when i turn the key on.
Reply With Quote
  #4  
Old 12-10-2010, 11:22 PM
95powersmoker's Avatar
BOMBARDIER
 
Join Date: Mar 2010
Location: Ellensburg, WA
Posts: 2,959
Default

Your GPR sounds like its working. Did you remember to put the caps back on the glow plugs? How did your UVCH look?
Reply With Quote
  #5  
Old 12-11-2010, 12:25 AM
CSIPSD's Avatar
Diesel Bomber
 
Join Date: Sep 2007
Location: Bend OR
Posts: 7,639
Default

Quote:
Originally Posted by 99stackedpowerstroke View Post
not on mine i only have on top of motor, and it was a bad relay from the start, i jumped the relay, and i heard my glow plugs kick on, so i jumped it for 10 seconds and it fired right up, so i replaced it and now it works perfect and i have power to the other big stud when i turn the key on.

Well you have a Early 99 then... Good thing to know when your modding your truck!

Early 99's dont have the intake air heater which is the second relay on top of the motor.


Sounds like you got it worked out!
Reply With Quote
  #6  
Old 12-11-2010, 12:29 AM
99stackedpowerstroke's Avatar
Diesel Wrench
Thread Starter
 
Join Date: Dec 2009
Location: southeast Iowa
Posts: 687
Default

yes sir, its like mid 98, ya 3rd relay in less than a year,
Reply With Quote
  #7  
Old 12-12-2010, 10:20 PM
OceanDiesel's Avatar
Diesel Enthusiast
 
Join Date: Mar 2010
Location: Norwalk, IA
Posts: 371
Default

3rd in less than a year? I got mine from some company outta SC on E-Bay for $30 a year and a half ago. I busted a post (over tightened...oops!) during install, i called to get another and they replaced it free no questions asked. I just wished I had the # to give ya.
Reply With Quote
  #8  
Old 12-13-2010, 10:56 AM
CSIPSD's Avatar
Diesel Bomber
 
Join Date: Sep 2007
Location: Bend OR
Posts: 7,639
Default

Quote:
Originally Posted by 99stackedpowerstroke View Post
yes sir, its like mid 98, ya 3rd relay in less than a year,
Napa... GPR109... about $34 bucks. I have not replaced one in about 2 years now.

There is also the Staycor, which is a tough SOB but about $100 bucks.
Reply With Quote
  #9  
Old 12-13-2010, 09:34 PM
OceanDiesel's Avatar
Diesel Enthusiast
 
Join Date: Mar 2010
Location: Norwalk, IA
Posts: 371
Default

$34? Everyplace I called gave me quote of $45-60
Reply With Quote
  #10  
Old 12-13-2010, 10:30 PM
99stackedpowerstroke's Avatar
Diesel Wrench
Thread Starter
 
Join Date: Dec 2009
Location: southeast Iowa
Posts: 687
Default

oriellys here in town wated 78 for theirs i warranted a buddys haha
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
7.3 idi glow plug problems/Question Metz1234 Ford 83-94 6.9 and 7.3L General 3 03-03-2016 11:20 PM
glow plugs rkp209 Chevy/GMC Duramax 2011 LML 1 01-10-2016 11:32 AM
1985 6.9l Glow Plugs wont turn on with manual switch GT_Eleanor Ford 83-94 6.9 and 7.3L General 0 09-14-2015 11:52 AM
truck will not heat glow plugs or start stripmechanic Diesel In Distress - Support Ticket 14 04-06-2015 10:10 PM
glow plugs staying on hardwired Ford Powerstroke 03-07 6.0L 8 01-23-2015 05:30 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 04:19 PM.