1997 Powerstroke Dies when warm/Hard Start - Diesel Bombers



Ford Powerstroke 94-98 7.3L Discussion of 94-98 7.3 Liter Ford Powerstroke Turbo Diesels

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-02-2009, 06:41 PM
Newbie
Thread Starter
 
Join Date: Jun 2009
Posts: 5
Default 1997 Powerstroke Dies when warm/Hard Start

Hey guys! New to the forum and have run into a problem and would like your advice.

I have a 97 Ford f350, 7.3l,a/t, and 221k on the truck. The truck takes a bit to get started then will die when the motor warms up. and will not refire till motor cools down. The truck will also die on decceleration when the motor gets warm. I have searched and have done the following

* Swaped IDM
* Replaced CPS
* Replaced injector o-rings
* Replaced IPR o-rings
* New Glow plugs
* One of the glow plug harness' had a bad wire so i swaped that too
* Oil/Filter
* fuel filter
* Unpluged the EBPV
* Unpluged fuel heater

Where should I go from here?
Reply With Quote
  #2  
Old 06-02-2009, 07:26 PM
CSIPSD's Avatar
Diesel Bomber
 
Join Date: Sep 2007
Location: Bend OR
Posts: 7,639
Default

Quote:
Originally Posted by Grama View Post
Hey guys! New to the forum and have run into a problem and would like your advice.

I have a 97 Ford f350, 7.3l,a/t, and 221k on the truck. The truck takes a bit to get started then will die when the motor warms up. and will not refire till motor cools down. The truck will also die on decceleration when the motor gets warm. I have searched and have done the following

* Swaped IDM
* Replaced CPS
* Replaced injector o-rings
* Replaced IPR o-rings
* New Glow plugs
* One of the glow plug harness' had a bad wire so i swaped that too
* Oil/Filter
* fuel filter
* Unpluged the EBPV
* Unpluged fuel heater

Where should I go from here?

Welcome to the site!!!

Have you pulled any codes on it? Do you have a SES light when it will not restart? Checked Fuel pressure?

My guess, Bad IPR, or bad/weak fuel pump... But there WAG at this point. So it will start when the motor is cool, but once warm it will die? Do you have white smoke when trying to refire it? When it dies, are you just sitting at idle or is this happening while under way?
Reply With Quote
  #3  
Old 06-02-2009, 07:37 PM
Newbie
Thread Starter
 
Join Date: Jun 2009
Posts: 5
Default

Hey CSIPSD, I live in Bend too!

If I go out and fire up truck in the morning, it will crank for a bit then fire. Sometimes the idle will jump up and down for bit. The truck will then drive ok till it warms up. Then when you apply brakes it might just die almost like the CPS is out. Once the motor gets warm it starts to lose a little power then will just die the next time it gets to around idle and wont start again for a couple hours. I havnt checked fuel pressure but sure will.

Could it also be that i might have the wrong CPS? My truck is a 97 but the motor is stamped 96 on the front of the HPOP res. I was told that 97s are different then 96 and older CPS'.

Right now Im also not getting any codes.

Last edited by Grama; 06-02-2009 at 07:41 PM.
Reply With Quote
  #4  
Old 06-02-2009, 07:57 PM
CSIPSD's Avatar
Diesel Bomber
 
Join Date: Sep 2007
Location: Bend OR
Posts: 7,639
Default

Quote:
Originally Posted by Grama View Post
Hey CSIPSD, I live in Bend too!

If I go out and fire up truck in the morning, it will crank for a bit then fire. Sometimes the idle will jump up and down for bit. The truck will then drive ok till it warms up. Then when you apply brakes it might just die almost like the CPS is out. Once the motor gets warm it starts to lose a little power then will just die the next time it gets to around idle and wont start again for a couple hours. I havnt checked fuel pressure but sure will.

Could it also be that i might have the wrong CPS? My truck is a 97 but the motor is stamped 96 on the front of the HPOP res. I was told that 97s are different then 96 and older CPS'.

Right now Im also not getting any codes.
Sounds like a bad IPR... I should be in town this weekend and could take a look at it for you. I have AE and can run some tests on it.

What maintance have you done to it over the years? Injectors? HPOP? anything major?
Reply With Quote
  #5  
Old 06-02-2009, 08:24 PM
Newbie
Thread Starter
 
Join Date: Jun 2009
Posts: 5
Default

I just bought the truck from a buddy, so im not sure on the what hes done. He told me he did have the stealership replace an injector or two. Ive got access to a Snap-on scan tool if that would help as well. That would be great if you could check it out.
Reply With Quote
  #6  
Old 06-02-2009, 08:52 PM
CSIPSD's Avatar
Diesel Bomber
 
Join Date: Sep 2007
Location: Bend OR
Posts: 7,639
Default

Well give me a call this weekend, maybe saturday if that works and I will run into town and take a look...



503-969-7415...

Joe
Reply With Quote
  #7  
Old 06-02-2009, 09:47 PM
Newbie
Thread Starter
 
Join Date: Jun 2009
Posts: 5
Default

Your the man Joe, Ill give ya a call on saturday.
Reply With Quote
  #8  
Old 06-05-2009, 06:29 PM
IHWelk49's Avatar
Diesel Fan
 
Join Date: Oct 2008
Location: Northern Indiana
Posts: 30
Default

agree with Joe sounds to be like a bad IPR
Reply With Quote
  #9  
Old 07-04-2009, 11:32 AM
Newbie
Thread Starter
 
Join Date: Jun 2009
Posts: 5
Default

Sorry guys been super busy, Had a chance to toss in a new IPR with no luck. It still takes about 10 seconds to crank then when she gets warm she dies, then wont fire till shes warm.
Reply With Quote
  #10  
Old 07-06-2009, 11:24 PM
robammerman's Avatar
Diesel Enthusiast
 
Join Date: Mar 2009
Location: Grant, MI
Posts: 124
Default

I'd start looking at the HPOP.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
wont start without starting fluid, dies under 1k GasItOut 12 Valve 2nd Gen Dodge Cummins 94-98 35 07-22-2015 01:11 PM
6.0 2006 powerstroke start problems after work done cjgregory Diesel In Distress - Support Ticket 0 03-31-2015 01:45 PM
No Start: Ford 6.0L Powerstroke FICM Diagnosis & Replacement makuloco2000 Ford Powerstroke 03-07 6.0L 1 02-15-2015 02:31 PM
'07 powerstroke died and wont start ughhhhhh southernbelle14 6.0L Performance 0 12-29-2014 10:53 AM
1996 F-250 7.3 powerstroke no start no white smoke Domrig13 General Diesel Related 0 12-12-2014 01:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 06:28 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.