glow plug controller truck won`t start! - Diesel Bombers

Go Back  Diesel Bombers > Ford Powerstroke > Ford Powerstroke 03-07 6.0L
glow plug controller truck won`t start! >

glow plug controller truck won`t start!

Ford Powerstroke 03-07 6.0L Discussion of 6.0 Liter Ford Powerstroke Turbo Diesels

glow plug controller truck won`t start!

Reply

 
 
 
  #1  
Old 06-30-2009, 11:05 AM
Newbie
Thread Starter
Join Date: Jun 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default glow plug controller truck won`t start!

does anybody know the signs and syptoms of the controller/ glow plugs/ replacement.
2 weeks ago truck 04 F250 6.0 ran fine then for no reason would not crank up. I climbed underneath and tapped on the fuel pump and it worked.

It ran fine until this morning, It would not crank up I removed the fuel filter to check that pump was working and it was. The engine will turn over but won`t fire?
I think it is the glow plug control module. anybody have any thoughts or advice as to checking it or other problems in troubleshooting?
 
Reply With Quote
  #2  
Old 06-30-2009, 01:59 PM
Diesel Fan
Join Date: Mar 2009
Posts: 93
Thanks: 0
Thanked 2 Times in 2 Posts
Default

My brother had the same problem when we were out at coral pink a few weeks ago. truck was running fine and when he went to start it on sunday it did just like your truck did. figured out it was the glow plug module . just gave it a snort of diesel dope and and it fired up. is in the shop right now for the module, head gaskets, heui pump gasket(aka the high pressure oil pump) and what ever else they find wrong with the cab off at this time. i should also add that is it blowing white smoke? if not then I would check the fuel pump shut off switch that is located in the right side kick panel, that has happened before to him also and he didn't hit any big bumps.and also is the injectors making a snapping sound when the engine is cranking, that is a sign that the injectors are working and the HEUI pump is sending oil to the injectors. good luck keep us posted and welcome to DB
 

Last edited by yankeeflatsdiesel; 06-30-2009 at 02:04 PM. Reason: neede to add a few things
Reply With Quote
  #3  
Old 07-01-2009, 08:39 PM
Newbie
Join Date: Jun 2009
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

sorry to pass this on my truck done the same thing ran fine and one morning went out to crank it and nothing. ran both batteries dead and it was my ficm.fuel injection control modular the part from ford was $900 if that is the problem try to find one in a salvage yard
 
Reply With Quote
  #4  
Old 07-04-2009, 10:47 PM
Big Angry Hillbilly's Avatar
Diesel Wrench
Join Date: Jan 2009
Posts: 513
Thanked 45 Times in 40 Posts
Default

A salvage yard one will likely be no better. Bite the bullet and buy a new one, and you'll need it installed at the dealer - it needs to be programmed.

At least with a new one you get a warranty.
 
Reply With Quote
  #5  
Old 01-18-2010, 07:11 AM
Newbie
Join Date: Jan 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Im having the same problem, have been for months. Trying to narrow it down to something and think maybe its the glow plug control module. Started parking it in the shop 60 deg. and would still start difficult. When the engine block heater is plugged in it starts fine. Yesterday my brother came over we put a volt meter on the battery and tryed starting it read say 12 volts, no start, turn key off. Then my brother, while im in the truck, started moving the plugs on the glow plug contro module and me turning the key noticed that the volt meter would drop down by a volt and also noted inside dome light dimming ever so litely and a slight drop in pump valocity sound, this time truck fired right up no white smoke. We are thinking its the its the GPCM and when we wigle the wire hook up that it then starts working intermittedly? Any thoughts?
 
Reply With Quote
  #6  
Old 01-21-2010, 07:13 PM
crewed powerstroke's Avatar
Diesel Enthusiast
Join Date: Jun 2009
Location: Pennsylvania
Posts: 319
Thanked 32 Times in 24 Posts
Default

Not to sound like a smart a$$ or any thing but it sounds like you might be on to your problem, loose wire . Are the clips broken on any of the connector plugs?

Oh yeah, before I forget,
 
Reply With Quote
  #7  
Old 04-14-2018, 03:58 PM
Newbie
Join Date: Apr 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default 06 6.0 no start

I have a 06 6.0 that has been running and starting fine have been having some longer cranks to get it started then one morning walked outside started it drove 2 hours to work parked it next day went to start it and nothing no start cranked till dead well charged it and came back the next day and I know by no means to never use starting fluid but had to do something and get it off the customers property I was working on but it started and I drove it 2 hours home and ran great but got home killed it came back out same thing no start just cranking only code it's throwing is the po6077 glow plug 7 Open could it possibly be my gpcm out or am I looking more at a hpop leak or icp problem also unplugged icp made no difference in starting also Ficm is good and voltage is at 48 oil pressure gauge is jumping up wile cranking in at a loss
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Metz1234
Ford 83-94 6.9 and 7.3L General
3
03-03-2016 11:20 PM
schmauster
Chevy/GMC 6.2L and 6.5L
22
07-26-2015 12:33 PM
94chevy6.5
Tech Article Submission
6
06-16-2015 01:45 AM
stripmechanic
Diesel In Distress - Support Ticket
14
04-06-2015 10:10 PM
ajwright64
Ford Powerstroke 99-03 7.3L
0
02-04-2015 10:36 PM


Thread Tools
Search this Thread
Quick Reply: glow plug controller truck won`t start!


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.