6.5L runaway when idling - Diesel Bombers

Diesel In Distress - Support Ticket Need Help ? Broke Down Or in Urgent Need Of Assistance Post Here , Thread Will Be Priority and You have the ability to close your own thread when its fixed . If You Do Not Reply in 10 Days your thread will be closed as we will assume its fixed , You can Reopen YOUR Discussion Topic if you wish .

6.5L runaway when idling

  #1  
Old 03-30-2018, 02:56 PM
Tahoe2DR's Avatar
Newbie
Thread Starter
Join Date: Mar 2018
Location: Washington, DC
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default 6.5L runaway when idling

Hi,
I'm looking for advice on a 1999 6.5L. Here's the symptoms:

With the first PMD, the engine would idle normally but if I tapped the accelerator the RPMs would spike up.
With a second PMD, the engine would idle normally for 10-20 seconds but then RPMs would spike up without me touching the accelerator.

I get a scanner code P1653

Could both PMDs be faulty? I did the LiftPump test, fuel comes out the T-vavle hose. The previous owner replaced the IP several years ago but I don't know the quality of the current pump.

Any assistance appreciated. Thanks
 
  #2  
Old 09-26-2018, 10:28 AM
Tahoe2DR's Avatar
Newbie
Thread Starter
Join Date: Mar 2018
Location: Washington, DC
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The new PMD seems to have settled down now.
This thread can be closed. Thanks.
 

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.