Possible limp mode?!?!? - Diesel Bombers



Chevy/GMC Duramax 04.5-05 LLY Discussion of Chevy and GMC Trucks with LLY Duramax Turbo Diesel Engines

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-13-2011, 03:03 AM
cbsmoraine's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Jan 2011
Location: TEXAS
Posts: 149
Question Possible limp mode?!?!?

So, doing about 70 on the highway, have about a quater tank of fuel, go to pass a slower car and bam, nothing. pressing the pedel and not even a rpm jump. engine stays the same rpm and speed doesnt increase. so i decel, at about 55 i press the pedel to the floor, i get a slight rpm jump but nothing like pedel to the floor rpm jump. it rev's to about 2000 and mph jumps to 65, so i exit, cause it sounds like the engine is starving for fuel. pull in to the gas station, check all the fuel lines, check the fuel filter to see if my previous prob had come back, nothing. Entire fuel sys was fine. i fill the tank, start up, and rev the engine and bam hits rev limiter no prob. so i say f'it and hop back on the highway, haven't had a prob since. (its been 3 days) throttle response is great, turbo spools fine, fuel filter is clean. oil is new (1400 miles) same with air filter. so any one heard of this? what should i look for? pc glitch? random prob?
Reply With Quote
  #2  
Old 02-13-2011, 11:41 AM
BriteWhiteRam's Avatar
Diesel Bomber
 
Join Date: Mar 2009
Location: Alberta, Canada
Posts: 1,070
Default

do you have an airdog or FASS?
Reply With Quote
  #3  
Old 02-13-2011, 03:26 PM
cbsmoraine's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Jan 2011
Location: TEXAS
Posts: 149
Default

bone stock, minus the aluminum WIF sensor plug and a intake resinator delete.
Reply With Quote
  #4  
Old 02-14-2011, 09:48 AM
Rttoys's Avatar
Diesel Bomber
 
Join Date: May 2007
Location: Houston, TX
Posts: 1,221
Default

Have you checked for any codes to see if it did actually limp?
Reply With Quote
  #5  
Old 02-14-2011, 02:55 PM
cbsmoraine's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Jan 2011
Location: TEXAS
Posts: 149
Default

didnt check for any silent codes. but i never got a C.E.L. so i dont know.
Reply With Quote
  #6  
Old 02-14-2011, 04:16 PM
Rttoys's Avatar
Diesel Bomber
 
Join Date: May 2007
Location: Houston, TX
Posts: 1,221
Default

You can have codes without the CEL coming on. Kind of strange for it doing what it did, though.
Reply With Quote
  #7  
Old 02-14-2011, 10:27 PM
Headcase98002's Avatar
Diesel Fan
 
Join Date: Feb 2011
Location: Edinburgh, Indiana
Posts: 32
Default

Alright, Im a Duramax Mechanic at my local dealership. 4 things that will cause this.
#1 - Air filter(the factory Blue Donaldson Air filter will get clogged real quick replaced it and get something with a white filter element) this could have been your issue cause the turbo will actually tear the filter apart alowing air to bypass the fitler.
#2 - Fuel filter(you need to change your fuel filter at a maximum of every 15000 miles)
#3 - EGR Valve(this will become clogged in 2006 and up, the factory will reprogram your ECM to allow the dealer to clean your EGR valve with the Tech 2).
#4 - Injector Harness break( your engine will go into limp mode and only run on 4 cylinders. it will have a reall lound crackle sound like starting it on ether. This is a porblem on all lly and lbz engine. #2 and & 7 injector connectors gets replaced. GM sells a kit to lengthen the harness do it is not in a bind pulling the pins out of the connectorL

#4 sounds like your problem. it can come and go. but it will always come back.
Reply With Quote
  #8  
Old 02-14-2011, 10:40 PM
cbsmoraine's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Jan 2011
Location: TEXAS
Posts: 149
Default

could be #4 cause it did act like that, but it didnt make the clank niose. it just refused to make any power, and rpm any anything. it just ran like it was starving for fuel or air. i had a four wheeler that did the same thing but i dont want to treat my truck like a quad. quad turned out to need the injector cleaned. but i put injector cleaner in the truck before we left on the trip. changed the oil and filter. and air filter. from what i gather i have to go get the codes checked, cause it guess it can throw a code with out throwing the CEL
Reply With Quote
  #9  
Old 02-15-2011, 12:27 PM
Headcase98002's Avatar
Diesel Fan
 
Join Date: Feb 2011
Location: Edinburgh, Indiana
Posts: 32
Default

yes its possible.
Reply With Quote
  #10  
Old 02-15-2011, 01:46 PM
Diesel Enthusiast
 
Join Date: Aug 2010
Location: Waterloo, Iowa
Posts: 160
Default

I just had this happen to my car (volvo). It was really cold out and the thing had no power at all. Put it in neutral and she would hit the limiter but in gear it had nothing. The last couple days its been about 40 out and I went to move the car and it was fine. Not really sure what the problem was.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Limp mode problem 6.4 king ranch Ford Powerstroke 08-10 6.4L 0 04-15-2015 04:53 AM
Limp mode ClintD. Chevy/GMC Duramax 06-07 LBZ 2 03-23-2015 05:37 AM
My 2011 3500 Cummins randomly goes into limp mode...please help syctaz 6.7 Liter Dodge Cummins 07.5-12 7 03-03-2015 10:23 AM
limp mode To fast Chevy/GMC Duramax 04.5-05 LLY 2 02-10-2015 10:30 AM
Limp mode Brandanllewellyn Chevy/GMC Duramax 07.5 -10 LMM 0 10-20-2014 09:09 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:15 PM.