Go Back  Diesel Bombers > The Engine Room > Audio Equipment/Electrical
No start issue-intermittent power to fuel shutoff solenoid >

No start issue-intermittent power to fuel shutoff solenoid

Audio Equipment/Electrical Discussions Based on Automotive Stereo Equipment Such As Amps , Head Units & Speakers Including Installation and System Set Up Information. Electrical or wiring issues on anything that requires wiring.

No start issue-intermittent power to fuel shutoff solenoid

  #1  
Old 02-02-2016, 06:50 AM
Newbie
Thread Starter
Join Date: Feb 2016
Posts: 1
Likes: 0
Liked 0 Times in 0 Posts
Default No start issue-intermittent power to fuel shutoff solenoid

Hi, disregard spelling of Diesel in my profile name, eyes are a little blurry from hours of searching!! Hopefully moderators can fix it so I don't look like the idiot that I really am!! Haha
Patient of the day: 89 W350
I have been fighting with keeping this ol girl running long enough to plow since we got her last year, about this time. Previous owners wired up flashing lights, dump body, body lights, etc and didn't seem to care where they got their power from!
At this point I have disconnected dump body, flashing lights, and plow from power(I believe). I've got a major short in the interior lights, so that fuse is pulled. Up until a month ago she was starting and running for a few weeks at a time, then a short? somewhere would rear its ugly head and fry the VR and boil the battery. The voltage would get up to 18.5-19.0!

Been chasing J2 blue ignition wire looking for faults. Found a bunch, fixed. Got it to charge 14.8-15.02 which I should happy with, or so I was told.
About two weeks ago I pulled the section of wiring harness that connects right below wiper motor, and feeds fuel heater, fuel pump, cold start advance, temp sensor, water in fuel sensor, and fuel shut off solenoid. Truck was starting and running before I did this!

Found and fixed 2 chaffed wire that were grounding on block, found and fixed 3 connectors, 2 in plug, one slide on that was hanging by one or two wires(that was the one for fuel shut off solenoid). Cleaned it all up, put it back together and NO start!

After some more searching and testing I traced it to no power @ fuel shut off solenoid. Tested it, ran jumper from battery, fed it 12v, got click. So solenoid appears to work if gets power.
Interesting note: when solenoid does get power from harness it is only 10.8, where as other connectors(J2 ignition) gets 12+, so somewhere in that circuit I'm losing 2v.

For a little while I could stick a probe into connector below wiper motor and get power, so thought issue was there. Took that wire right out of plug and wired it direct. That evening she started up multiple times just fine. Went out yesterday am to try it, and nothing! No power to solenoid anywhere. I've tested it at each connector along the way and as far as coming out of air heater controller box.

I'm thinking all that overcharging might have melted some connections inside that air heater controller(AHC). I have been hesitant to dig all the gel stuff out and see, since it 'seems' to be controlling the other functions okay. The intake relays and heaters work when needed. J2 goes in and out of that box. Wire for cold start advance too. And message center wire.
Interesting note, temp sensor gets 'flashing' power(don't know if thats right, but its what it does those wire also come out of AHC box. After that truck has started, sometimes the 'wait to start' light flashes while running. Maybe a bunch of things are talking to each other inside that box that shouldn't be??? I have only been able to find 1 of those boxes so far, $200, no guarantee. Dealers got nothing. Got calls out to junk yard around here, but same age???
So...thanks for reading all that. I wanted to give a good background on what I've done so far.

My questions are:
Should I dig out gel and see whats going on in that box?
Should I just put fuel shut off solenoid on switch and forget about box controlling it?
Can I just run a hot wire to solenoid temporarily so we can plow Tomorrow!?

Thank you guys all so much for all the knowledge you have shared! I've been able to find answers to a lot of my questions in the past just by searching! This one I need a little help on!
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.