Glow Plug Testing and issues... - Diesel Bombers

Glow Plug Testing and issues...

 
 
 
 
  #1  
Old 10-02-2009, 12:08 AM
CSIPSD's Avatar
Diesel Bomber
Thread Starter
Join Date: Sep 2007
Location: Bend OR
Posts: 7,639
Thanked 638 Times in 482 Posts
Default Glow Plug Testing and issues...

"Well, cold weather is certainly upon us for most of the states and I thought it would be useful to have this around for those who have noticed hard starting in the mornings due to the cold temps.

The main thing that is going to make or break a cold start for your PSD is the glow plug system. This is barring any gelled fuel, etc. The glow plugs, and glow plug relay system can be tested, and are fairly inexpensive / straight forward to replace any components needed.

The first and easiest test is to check the glow plug relay.

1) Let the truck sit overnight in fairly cold temps ( < 45 ) this will require the glow plugs to activate for a good amount of time for the truck to start properly.

2) The test part can be done several ways, first of all if you have a voltmeter, dial it up to the correct setting for 12V systems, ground it to a good ground, and put the + lead on the right/back side of the glow plug relay. With the key off, that terminal should read zero, while the other one (which connects to the battery) should read +- 12V at all times. You want to measure the one with zero voltage.
When the key is turned on, the one that had zero should go up to 12V and stay there for 30sec - 2min. This is feeding the glow plugs 12V to heat them up.

3) Have someone turn the key on for you, or turn it on and get back around to your tester quickly, and see if you have 12V across the relay. If you do, see how long the relay stays activated, if it goes off very quickly it's not allowing the gp's enough time to heat up and the truck is going to start rough. If the relay fails this test, replace it.

2-3a.) Some alternate methods to above, instead of using a voltmeter, jumper across the relay either with a screwdriver (which will cause sparks until you make a good contact) or with a set of jumper cables from the hot + terminal on one of your batteries, to the gp side of the relay. Make the connection for about 45 seconds, then immediately try to start the truck. If it fires up nicely, whereas it was struggling before, the relay is bad.

4) If the relay passes the test, and is good. Or if you replace the relay and still experience hard starts, you will need to move on to testing the glow plugs themselves. This can be done quite non-invasive, only requiring you to pull the valve covers if you find a bad glow plug, to replace it / them.

5) There are also a couple ways to test the glow plugs, you will need either a test light, or a good voltmeter that will read in ohms.

5a) Voltmeter method - Remove the large rectangular plug leading to the valve covers on either side of the engine. This plug powers your glow plugs and injectors. The 2 outside pins are your glow plugs, the 4 inner ones are for the injectors. () () () () () () () () Blue is the Glow Plugs, Red is the injectors.Be very careful not to insert your test lead into one of the injector pins. The IDM feeds the injectors 110V and could cause a lot of sparks if it happens to try and actuate the injectors while you're testing, and could worse destroy the IDM, so steer clear of those and make sure you test only the 2 outer pins on each side of the plug.
Connect the ground lead of your voltmeter to a good ground, and insert the positive + test lead into the first glow plug pin.
A good glow plug will read btwn 0.8 - 1.2 ohms a weak glow plug will have much less resistance, and a completely dead one will have unlimited resistance through it because the electrode is internally burned out. Make note of the plugs that are out of range based on the cylinder number, and replace them. The cylinders are numbered 1-3-5-7 on the pass side, front to back, and 2-4-6-8 on the driver's side, front to back.

5b) The test light method - See 5a and substitute voltmeter for test light, if you don't have a voltmeter. Connect the negative end of the test light to a good ground, and insert the test light into the outer 2 terminals on the plug. If the test light illuminates the plug is still working. If the test light does not illuminate, the plug is bad. Make note of the bad ones and replace.
The disadvantage to this method is that it won't tell you if a glow plug is weak, only if it is completely burned up.


*note this does not apply to california emissions equipped vehicles (cali trucks) or the Excursion with 7.3L PSD engine (all years) as they use a controller to actuate the glow plugs instead of a relay. A bad glow plug on these trucks will throw an engine code.
"
Replacement parts - For the glow plug relay your choices are to buy a stock replacement ($$$), get a GPR-109 from NAPA for less than 30 bucks. This one will work, but some have had issues on them not lasting as long as the stock unit. There is a good option from Stancor, the part number for which I will let someone post. Or you can always find one that's designed similarly and rated for the voltage/amps that the stocker is or better, and use it.
Here is a link for the Stancor unit: http://www.alliedelec.com/Search/Pro...DA8041ECE1 7F

For glow plugs, you want to use only Motorcraft or Bosch plugs. This is very important as the Autolite / Champion cheap brands have a bad reputation for swelling up, burning out prematurely, and breaking off in the head. The motorcraft part number is ZD-11.

The relay is simple to change, disconnect the 2 large terminals, and the smaller ones, unbolt the relay, and install the new one.

The glow plugs are located under the valve covers. Remove the vc's and you will see 4 white wires, with black plug ends connected down beside the injector. Remove the plugs from the gp's, and remove the gp's with a 10mm deep socket.

Here is a pic of the glow plug relay. It is the rear most one, the on under the hose is for 99.5-03 trucks and is the AIH relay. The terminal on the left in the pic is the constant 12V to the battery, the other one on the right in the pic is the one you want to test.


Read more: https://www.dieselbombers.com/ford-p...#ixzz0Skg8IvPa
 
The Following User Says Thank You to CSIPSD For This Useful Post:
MatieA (08-03-2010)
  #2  
Old 10-13-2009, 11:32 AM
Newbie
Join Date: Oct 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

what controls the time the glowplug relay stays on?
 
  #3  
Old 10-20-2009, 06:01 AM
Newbie
Join Date: Oct 2009
Location: Eatonville, WA
Posts: 6
Thanked 0 Times in 0 Posts
Default

Your link or the Stancor glow plug relay doesn't work.

Here is the link I have come across for the unit. It is part number 586-902
Stancor PN 586-902

Or

Stancor PN 586-902
 

Last edited by charliesnyder; 10-20-2009 at 06:08 AM.
  #4  
Old 01-13-2010, 05:46 PM
DieselDanBoy's Avatar
Diesel Wrench
Join Date: Sep 2009
Location: Torrington CT
Posts: 574
Thanked 28 Times in 28 Posts
Default

ok now there is a gp controller on all of the 7.3's. my excursion does in fact have a controller with a relay, and so does my buddies f350.

but i do have a question....
i was told there is a fusable link from the controller to the relay that can go bad. is this true? and where is it located? i am actually having this problem with a customers f350, it has a new relay, new glow plugs, and the fuses are good. and the system still does not work. relay has power and the light on the dash runs for about 15-20 seconds, normal time, so the controller is working. just no signal from the controller is getting to the relay.
 
  #5  
Old 11-04-2010, 08:21 AM
dark knight cummins's Avatar
Diesel Fan
Join Date: Sep 2010
Location: Grey County
Posts: 53
Thanks: 0
Thanked 1 Time in 1 Post
Default

just replaced the glow plugs in our 97 250. made a huge difference in power, fel economy, and cold starting. the thing was a bitch to make move to be honest now it drives great. still doesnt like towing though
 
  #6  
Old 12-11-2010, 12:36 PM
Newbie
Join Date: Dec 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Checked my GPs through the harness and thought i had a bad one but come to find out the VC gasket was bad along with the plugs, had to order the kit no one had the thing in stock
 

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.