97 Wont Go Into O/D - Diesel Bombers

94-98 12V Cummins 5.9L P7100 Tech Talk '94-'98 5.9L Cummins 12-Valve P-9100 Tech Articles

97 Wont Go Into O/D

 

 
 
 
  #1  
Old 07-12-2007, 05:11 AM
Diesel Enthusiast
Thread Starter
Join Date: Mar 2007
Location: Minnesota
Posts: 121
Thanks: 0
Thanked 9 Times in 9 Posts
Default 97 Wont Go Into O/D

Any one have any ideas on why my 97 wont go into O/D?
 
  #2  
Old 07-12-2007, 11:55 AM
Benjamin's Avatar
Bombardier
Join Date: Mar 2007
Location: Da' Dirty South
Posts: 9,655
Thanked 607 Times in 502 Posts
Default

TPS? chack the tranny fluid while it is idling in neutral..... mine did that and it was 3 quarts low checking it that way but in park it read fine.......
 
  #3  
Old 07-12-2007, 10:26 PM
Diesel Enthusiast
Thread Starter
Join Date: Mar 2007
Location: Minnesota
Posts: 121
Thanks: 0
Thanked 9 Times in 9 Posts
Default

The fluid is full. I just flushed it, replaced the filter and filled it up. I'm hoping it is something other than the TPS. I'm not willing to pay for one since I'll be putting a 5spd in it soon. I just want to drive it for a while.
 
  #4  
Old 09-05-2007, 01:38 AM
hendo's Avatar
Diesel Fan
Join Date: Sep 2007
Location: so cal
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i had the same problem with my 94 ctd 47rh tranny and had learned that the computer was getting wrong info from the tranny temp sender so i tricked the computer by putting in a 25c 1000ohm resister (radio shack)in between the two wires comeing from the stock temp sender and now all is fine
 
  #5  
Old 09-05-2007, 06:15 AM
Banned
Join Date: Mar 2007
Location: Perry Co. Ohio
Posts: 29,849
Thanked 3,296 Times in 1,639 Posts
Default

Reset the Apps

Resetting the APPS causes the ECM to 're-learn' where the throttle is at all times when something happens to cause the ECM to not understand what the APPS is telling it like a dirty spot or something like that. What you do is disconnect BOTH batteries (yes you will need to reprogram your radio), turn the key on and wait for atleast 10 minutes, then turn the key off and hook up the batteries. Once that is done turn the key on but don't start it yet. SLOWLY and steadily push the throttle to the floor and SLOWLY and steadily release it. Turn the key off and then you can start it. You have now re-set the APPS.
Shield The Wire

Locate the 10-gauge ground wire that runs from the negative post of the passenger battery to the back of the alternator. This wire is often tan with a black stripe.
Starting at the back of the alternator loom where the tan/black striped wire heads for the battery, wrap the wire with a piece of tin foil about 4" - 6" in length. Wrap the tin foil with black electrical tape to secure it in place.
 

Last edited by DB Admin; 09-05-2007 at 06:18 AM.
  #6  
Old 09-05-2007, 06:22 AM
Banned
Join Date: Mar 2007
Location: Perry Co. Ohio
Posts: 29,849
Thanked 3,296 Times in 1,639 Posts
Default

Does your truck have a hard time making up its mind ... 2nd Gear or Third Gear?

Heres what you can do to try to fix your tranny lock up issues it seemed to of fixed mine ...

Locate the APPS wires
 
Attached Thumbnails 97 Wont Go Into O/D-rav4-001.jpg  
  #7  
Old 09-05-2007, 06:23 AM
Banned
Join Date: Mar 2007
Location: Perry Co. Ohio
Posts: 29,849
Thanked 3,296 Times in 1,639 Posts
Default

Seperate the Group of wires that are twisted together ...thats the apps Single going to the ECM ,,, it getting interferace from the other wires in the Split loom ...

Here it is pulled out of the Loom Below the ECM ,,

Note Remove Air Intake Manifold and Fuel Filter Housing for access
 
Attached Thumbnails 97 Wont Go Into O/D-rav4-002.jpg  
  #8  
Old 09-05-2007, 06:23 AM
Banned
Join Date: Mar 2007
Location: Perry Co. Ohio
Posts: 29,849
Thanked 3,296 Times in 1,639 Posts
Default

Here they are going into the ECM connection

Just Pull this set of wires away from the other and run them in a speperate split loom ,,,,then poak all the other wires back in the OEM split loom and put it all back together

Good Luck

DM
 
Attached Thumbnails 97 Wont Go Into O/D-rav4-005.jpg  
  #9  
Old 09-05-2007, 03:41 PM
Diesel Fan
Join Date: Apr 2007
Posts: 29
Thanked 0 Times in 0 Posts
Default

buddy of mine has a 98.5 that quit shifting into o/d. valve body in the tranny has a o/d solenoid on it. $110 from dodge dealer. im pretty sure if you get your truck hooked to the computer it will tell you if that is bad or not. but normally that costs alot. i would try autozone hookin it to their lil computer deal first to see if that would show anything since its free
 
  #10  
Old 09-06-2007, 07:18 AM
Diesel Enthusiast
Thread Starter
Join Date: Mar 2007
Location: Minnesota
Posts: 121
Thanks: 0
Thanked 9 Times in 9 Posts
Default

DM, thanks for all the info. It doesn't have any wierd shifting habits. It just wont go into OD. It goes 1,2,3 and then lock up like OD is locked out with the switch. I tried grounding the OD solenoid to force it into OD and that did not work. So right now I 90% sure its that solenoid. I'm going to take it to my buddys father-in-laws tranny shop next week. He said he'd hook it up to the computer for me and help me fix it. I'll be sure to report back what I find.
 
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
POWERSTROKEMANIAC
Ford Powerstroke 99-03 7.3L
4
11-18-2015 06:28 PM
Cutlass26
Chevy/GMC 6.2L and 6.5L
15
03-22-2015 06:46 PM


Thread Tools
Search this Thread
Quick Reply: 97 Wont Go Into O/D


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.