P0122 Code possible faulty ECM? - Diesel Bombers



24 Valve 2nd Gen Dodge Cummins 98.5-02 Discussion of 24 Valve 5.9 Liter Dodge Cummins Diesels with VP44 Injection Pumps
Sponsored by Trailer Plus

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-23-2012, 01:19 AM
RegansDiesel's Avatar
Diesel Fan
Thread Starter
 
Join Date: Sep 2011
Posts: 34
Default P0122 Code possible faulty ECM?

Hey Everybody, I pulled this code the other day from a used engine I throw in my truck. I have a new apps and IP and fuel psi is at 13. When idling my truck will not exceed 2000 rpm when I give it fuel. While driving it will do the same thing. I went through moparmans diagnostic steps and it led me to the conclusion ECM is faulty. What do these symptoms sound like to you guys? Thanks for the help.
Reply With Quote
  #2  
Old 05-23-2012, 02:26 PM
empty wallet's Avatar
Diesel Wrench
 
Join Date: Jun 2011
Location: New England
Posts: 666
Default

Your APPS voltage is WAY off... read this- apps adjustment
Reply With Quote
  #3  
Old 05-24-2012, 10:57 PM
RegansDiesel's Avatar
Diesel Fan
Thread Starter
 
Join Date: Sep 2011
Posts: 34
Default

Hey Empty wallet, I adjusted my apps and it fixed the p0122 from showing up, but I still have the same symptoms. It will only rev up to 2000 rpm still and cuts out between 16 and 1700. I have a p0341 code for the cam sensor could this be my problem? It starts up first turn of the starter only problem is its limited to 2000 rpm.
Reply With Quote
  #4  
Old 05-25-2012, 01:36 PM
empty wallet's Avatar
Diesel Wrench
 
Join Date: Jun 2011
Location: New England
Posts: 666
Default

Yeah cam sensor needs changing I'd say... or atleast check and make sure the plug is good and connected first. Does the tach drop off? That's another common symptom of crank & cam sensors going bad, that sensor is a bear to get to, in an awkward spot under/behind the vp44... what year engine do you have?
Reply With Quote
  #5  
Old 05-25-2012, 03:23 PM
RegansDiesel's Avatar
Diesel Fan
Thread Starter
 
Join Date: Sep 2011
Posts: 34
Default

The engine is in my 96 F350, and the tach runs independently off a tone ring on the harmonic balancer. I am going to order a cam sensor today or go get it from Phx. I am going to try and switch same year ecm's and see if that fixes it also if cam sensor doesn't fix it.The engine is also a 2001.
Reply With Quote
  #6  
Old 05-28-2012, 04:28 PM
RegansDiesel's Avatar
Diesel Fan
Thread Starter
 
Join Date: Sep 2011
Posts: 34
Default

Hey Empty wallet could the problem be that the problem is that the ECM is out of an auto and it doesn't have a signal from the trans so it's in limp mode? The other code with the cam sensor was no trans bus. I've been reading auto to manual swaps and a couple of them had the same issue with the it governing at 2000 rpm. Would a reflash of the ECM fix my issues?
Reply With Quote
  #7  
Old 05-28-2012, 06:05 PM
empty wallet's Avatar
Diesel Wrench
 
Join Date: Jun 2011
Location: New England
Posts: 666
Default

Reflash would probably be a good place to start.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OBD1 Code Reading dwmeehan Chevy/GMC 6.2L and 6.5L 1 09-06-2015 05:20 PM
Need help, P0193 code, Liberty CRD flash7210 Diesel In Distress - Support Ticket 0 07-05-2015 10:25 AM
2006 cummins ecm cleaning help Zachbishop 5.9 Liter CR Dodge Cummins 03-07 1 05-29-2015 08:21 PM
ECM or wiring faults? Lanceomni 24 Valve 2nd Gen Dodge Cummins 98.5-02 0 02-23-2015 10:26 AM
Where to have 2004 Cummins ECM Programmed? PerformanceAuto 5.9 Liter CR Dodge Cummins 03-07 2 01-15-2015 01:32 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 07:07 PM.