Alright boys what does this mean? - Diesel Bombers



24 Valve 2nd Gen Dodge Cummins 98.5-02 Discussion of 24 Valve 5.9 Liter Dodge Cummins Diesels with VP44 Injection Pumps
Sponsored by Trailer Plus

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-16-2013, 09:22 PM
SRTcummins's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Mar 2012
Posts: 139
Question Alright boys what does this mean?

Well my ABS and BRAKE light are on. I don't have abs when I brake and the pedal is soft. Brake fluid level is fine! I just think the ABS system went so what should I do?
Attached Thumbnails
Alright boys what does this mean?-image.jpg  
Reply With Quote
  #2  
Old 03-16-2013, 10:46 PM
RAW's Avatar
RAW RAW is offline
Administrator

iTrader: (1)
 
Join Date: Aug 2009
Location: Alberta
Posts: 6,218
Default

How is the power steering fluid, and how does it feel to steer? Brakes are hydro boost, could be a steering pump pressure issue.
Reply With Quote
  #3  
Old 03-16-2013, 11:08 PM
Bigg Redd's Avatar
Diesel Bomber
 
Join Date: Oct 2010
Location: TEXAS
Posts: 1,789
Default

Try changing out your PS fluid and flushing the system. could be that your fluid may be foaming up. Air bubbles entrained in your fluid are compressable and will cause a soft pedal. If you dont already use it, refill with ATF4 syn trans fluid. Could be something as simple as this.
Reply With Quote
  #4  
Old 03-17-2013, 12:56 AM
Diesel Fan
 
Join Date: Feb 2013
Posts: 84
Default

Does your speedometer work? If not, probably the speed sensor in the rear diff went out. It is easy to change.

If it does work or it doesn't and you just want to verify the problem, have someone use a scan tool to pull the trouble codes from your abs module. Diagnose it from the trouble code. Better than 90% chance if the speedo stopped, the speed sensor went out.

You also mentioned your pedal was soft. Is it abnormally soft. Hydro boost units can have a spongy feel to them if you compare them vacuum brake booster equipped truck. If you drive it normally, you will never notice it but if you are checking it and start pushing on the pedal hard you can over power the resistance of the hydro boost.
Reply With Quote
  #5  
Old 03-17-2013, 01:44 AM
Diesel Enthusiast
 
Join Date: Aug 2012
Location: butte mt
Posts: 360
Default

i have the same problem everything works but cruise i get a abs and brake light when i go over 60 mph i replaced the rear speed sensor before this problem bc the speedo quit it was good for about 2 months maybe i should try a dodge oem sensor?
Reply With Quote
  #6  
Old 03-17-2013, 08:19 AM
Mopar1973Man's Avatar
Diesel Wrench
 
Join Date: Mar 2007
Location: New Meadows, Idaho
Posts: 820
Default

Whoa a second guys.. Start out here first.
Mopar1973Man's Dodge Cummins Articles - Antilock Braking System (ABS)

Power steering pump or fluid will not trip the ABS / Brake light combo.

Brake fluid might but it would have to be seriously black.

Mine typically...


As for me I'm also fighting the ABS / BRAKE light. What happen to me is the driver side cable broke in half. So I bought the new driver side sensor and installed. But now the passenger side on the driver side are mismatched and no longer so the ABS computer keeps setting the code because of mismatch between left to right. So now I got to replace right side too. I always suggest replacing both sensors as a pair and I didn't heed my own warning and got hung on it too. (D'Oh!)

Last edited by Mopar1973Man; 03-17-2013 at 08:22 AM.
Reply With Quote
  #7  
Old 03-17-2013, 10:58 AM
SRTcummins's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Mar 2012
Posts: 139
Default

Mopar man. Thank you for saying that because my reservoir is dark. You can clearly see where the fluid is from te color of the fluid. But my pitman arm is leaking pretty bad that's we're the air bubble could com into play but the steering feels fine. SPEEDO still works its off by 5 but it's always been. I'm hooking up the scan gauge as we speak ill be back with codes
Reply With Quote
  #8  
Old 03-17-2013, 11:20 AM
Diesel Enthusiast
 
Join Date: Aug 2012
Location: butte mt
Posts: 360
Default

i dont think my truck has front abs sensors
Reply With Quote
  #9  
Old 03-18-2013, 07:21 AM
SRTcummins's Avatar
Diesel Enthusiast
Thread Starter
 
Join Date: Mar 2012
Posts: 139
Default

Ok so no codes.. Fluid is really dirty and I went for a drive down my street and the abs was working but after braking on the ice it finally came on and the abs stopped working! What now

---AutoMerged DoublePost---

Ok drove it for about an hour stop and go and the lights never came back on... HUH??

Last edited by SRTcummins; 03-18-2013 at 07:21 AM. Reason: Automerged Doublepost
Reply With Quote
  #10  
Old 03-18-2013, 09:16 PM
Diesel Fan
 
Join Date: Feb 2013
Posts: 84
Default

if the light is on it should have codes. make sure you have a scan tool capable of communicating with abs.
Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:52 PM.