Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Dodge Cummins > 5.9 Liter CR Dodge Cummins 03-07
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


2004 cummins 24v, the past few days i've noticed when idling, it spits and spudders, not all the time, also, when i put it into gear, and touch the pedal, it hesitates and the rpm's go up to about 2000, then it goes, as if, ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-16-2011, 12:59 PM
Newbie

   

Default 5.9 cummins 24v hesitation when accelerating

2004 cummins 24v, the past few days i've noticed when idling, it spits and spudders, not all the time, also, when i put it into gear, and touch the pedal, it hesitates and the rpm's go up to about 2000, then it goes, as if, lack of fuel, then it gets a boost of fuel, and its fine, it act's if its not getting fuel when i touch the pedal, but then does,(only hesitates half a second) it does not die, (all though it has stalled out) but that seemed to go away after i replaced the air filter and fuel filter, im leaning towards maybe throttle position sensor? or?... im stumped.
Reply With Quote
  #2  
Old 09-17-2011, 04:28 PM
Diesel Fan

   
View Member's Albums

Default

I would get a scan tool hooked up to it and get it checked out before i went throwing parts at it. I havn't been able to fix anything on mine without the scan tool.
Reply With Quote
  #3  
Old 09-17-2011, 04:38 PM
H.R.D's Avatar
Super Moderator
Status: Cummins: Been on the scene since 1919!

Jerrod.Stierwalt OSOdanger
   
View Member's Albums View Member's FaceBook Profile View Member's Youtube Account

Default

I would say TPS as well. Not sure if you can reset them on a CR like you can on a 24v. Some one with more in dept knowledge on CR's will chime in and help you out I'm sure.

H.R.D's Sig:
-Jerrod "OSO"-
_____________________________________________

2002 3/4 Ton Cummins 5 speed 4x4 X-cab SB
Volant CAI * Edge J/A HOT * Blue Chip VP * PDR HX40 * BD Short Shift * CFM+ * AD 100 * Flo~Pro 4" SS Duals
____________________________________________

DIESEL BOMBERS SUPER MODERATOR

CLICK HERE FOR SPONSORSHIP INFORMATION
CLICK HERE TO BECOME A PREMIUM MEMBER AKA BOMBARDIER
_________________________________________
Reply With Quote
  #4  
Old 10-17-2011, 07:27 PM
Newbie

   

Default

ive had a scan tool hooked up, says its under load when in park at idle? is that incorrect or normal? also, i replaced the sensor, still no luck, seems to only do it when i take my foot off the pedal, then reply my foot to the pedal, it hesitates for 3-4 seconds, like its floods itself out, then the rpms zoom to about 1500 and then it acts fine, maybe a bad iat sensor or map?
Reply With Quote
  #5  
Old 10-17-2011, 10:30 PM
Diesel Fan

   

Default

Originally Posted by H.R.D View Post
I would say TPS as well. Not sure if you can reset them on a CR like you can on a 24v. Some one with more in dept knowledge on CR's will chime in and help you out I'm sure.
I'll second that. I tried the apps reset on my 04 3500, didn't seem to change anything. I'm sure I'll be replacing mine soon. It's getting a new transfer case tomorrow.

Growler's Sig:97 2500 12V Straight piped KIA by baseball sized hail

04 3500 Quad Cab Long Bed; 5.9 CR; Banks stainless exhaust; looking at tuners next
Reply With Quote
  #6  
Old 10-18-2011, 08:56 PM
Newbie

   

Default

yeah, its in the shop....again .. hopefully they figure it out, its pretty bad now, if i keep my foot on the pedal, it seems to run pretty good, then i take it off, and go to press it again, and it acts 'stupid', hesitates, then picks up outta no where it goes fine, changes tone in the idle, almost sounds like a sticking injector, then it releases, and u can hear it, or to me sounds like it releases, then it runs fine, still, always have the pedal problem where if i let off it, and go to apply my foot back on it, hesitates.
they can figure it out cause im stumped on trying to 'guess' what could be wrong.

will post results if they figure it out.
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 02:02 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check