loses power - Diesel Bombers
Diesel Bombers
Go Back   Diesel Bombers > Dodge Cummins > 5.9 Liter CR Dodge Cummins 03-07
Search


5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Im working on a 2005 dodge 2500 cummins for a friend of mine. The truck is losing power after it warms up to around 120 degrees but it runs fine when is cold. Also when you press the brake and stop the truck it almost ... JOIN NOW TO REMOVE TRACER

loses power

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-12-2011, 12:45 PM
Newbie

   

Default loses power

Im working on a 2005 dodge 2500 cummins for a friend of mine. The truck is losing power after it warms up to around 120 degrees but it runs fine when is cold. Also when you press the brake and stop the truck it almost dies out like its being choked out. We have changed the thermostat, injector pump, lift pump, checked all the ground wires and electrical plugs, fuel filters and all. But it hasnt changed anything it has been to 2 diffrent shops that specialize in this type vehicle and they could never find anything wrong. the dodge dealership did everything they possibly knew to do but none of which did any good. It has a automatic trans and i am wondering if it could be something to do with it making the truck lose power and nearly die when you stop it. I have almost drivin my self crazy with this truck and I have no idea what could be wrong. Is there anyone that could maybe give me some tips or help?
Reply With Quote
  #2  
Old 03-12-2011, 06:38 PM
dangerous1965's Avatar
Diesel Bomber
After i got my License plate nobody wants to Play???

   

Default

Torque converter failure? How does the tranny fluid look? What are the rpm's doing? Did you try putting it in nuetral and see what happens? Do you have a rail guage?

dangerous1965's Sig:Goodies so far S&B intake,Silver bullet 64,AFE Stainless steel manifold, 90hp sticks, Head studs, 5" exhaust,SMARTY SSR,Airdog 150, 1/2" big Line kit,Gutted lift pump housing with draw straw Mod, T&C diesel CP-3,Custom intake with heater grid delete High Ram Intake, Built tranny, More guages than can be expected! 225 70r 19.5 tires at 80psi nitrous for laughs!
Reply With Quote
  #3  
Old 03-12-2011, 07:16 PM
Newbie

   

Default

I was thinking it could be the torque converter but im not sure. I checked the fluids and they were fine. The rpms will pick back up when you put the truck in nuetral but as soon as you go back to drive they fall agian. when your goin down the road after it warms up the rpm will barely pick up when you give it fuel. But it has no power after it gets warm. The dodge dealership and culumbus diesel both had the truck in there shop and both put gauges on it. They put a injector pump and lift pump but it didnt help anything there were no change in the truck.
Reply With Quote
  #4  
Old 04-01-2011, 07:05 PM
Newbie

   

Default Same trouble

Im experiencing the same problem with my 2005. It is my only vehicle, so it is urgent I figure this out. I have installed new injectors, and my snap on computer indicates fuel pressures are good. I installed a new FCA and it made the truck run like new until engine reaches operating temp. Lots of black smoke and no power. Trouble codes keep saying low voltage problems, but when checked voltage is correct. Have you solved your problem yet? Any information would be greatly appreciated.
Reply With Quote
 
 
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 04:46 PM.

Copyright And Legal Notice Links Of Interest

Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check


Diesel Bombers Dodge Cummins Forum Section Diesel Bombers Ford Powerstroke Forum Section Diesel Bombers Chevy GMC Duramax Forum Section