Lift pump issues - Diesel Bombers



5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Reply
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-20-2017, 08:39 PM
Newbie
Thread Starter
 
Join Date: Mar 2017
Location: New Orleans
Posts: 1
Default Lift pump issues

Hey guys kinda new to the diesel world and I've had my truck for 3 years now. 2005 ram with the 5.9. Love my truck and it's been great to me. No issues till lately. I haven't had a chance to install any gauges yet so I don't know what's exactly going on. The truck is stock. Anyway here's my problem. A few months ago the lift pump went out. Now I know they are prone to easy or fast failure. So I changed one out in November and it went out again last month. That one went out last week. And put a new one in and it apparently was bad out the box or I fried went I bumped the ignition to prime it. Is it possible I'm getting too much voltage to it to fry it? Thanks in advance.
Reply With Quote
  #2  
Old 04-23-2017, 09:06 AM
CumminsCoalRoller24/7's Avatar
Diesel Enthusiast
 
Join Date: Nov 2014
Location: San Antone - Tx
Posts: 410
Default

Possibly- I would think you'd fry your relay with too much juice. Try a volt meter to see how much power you are getting.

are you using an OEM pump or a cheapo?
Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 04:21 PM.