Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Ford Powerstroke > Ford Powerstroke 94-98 7.3L
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

Ford Powerstroke 94-98 7.3L Discussion of 94-98 7.3 Liter Ford Powerstroke Turbo Diesels

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


Hello fellow strokers.....I have a 95 ford powerstroke rollback that wont start. I`ve change the following fuel pump,all 8 injectors, new starter due to over cranking, switch valve for the tanks,high pressure oil pump. I had the truck hauled to a diesel shop and there ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-09-2012, 09:18 PM
Newbie

   

Default no start 95 ford powerstroke

Hello fellow strokers.....I have a 95 ford powerstroke rollback that wont start. I`ve change the following fuel pump,all 8 injectors, new starter due to over cranking, switch valve for the tanks,high pressure oil pump. I had the truck hauled to a diesel shop and there not getting nowhere with it. They change computer on it and nothing yet. They check all fuses fuel bowl heater everything checks out fine. They said today that the injectors are not firing up. The truck has good fuel in the bowl,oil pressure perfect their scan tool is not telling them nothing. NEED HELP BAD......... ANYTHING please......Could they maybe over looking something? Thank you .....
Reply With Quote
  #2  
Old 02-09-2012, 10:29 PM
95powersmoker's Avatar
BOMBARDIER

   
View Member's Albums

Default

What computer did they change? The IDM or PCM? How do they know the injectors aren't firing?

95powersmoker's Sig:
1995 F-250 Powerstroke, auto, 4x4
Gauges, Tymar Intake, SD dual exhaust, TW chip, Stage 1's

2000 F-250 SC/SB Powerstroke 4x4, Auto FOR SALE
Reply With Quote
  #3  
Old 02-10-2012, 01:13 AM
Newbie

   

Default

They change the pcm the first time now they saying the IDM. Still no fire. The truck was running like a bad out hell. Took it for a drive then she just quit on me . Got it back to the garage the full bowl was empty. Filled up the bowl nothing happen.
Reply With Quote
  #4  
Old 02-10-2012, 08:31 AM
Diesel Wrench

   

Default

If that shop doesn't have a scanner that will read it, get your truck the hell out of there before they suck even more money out of you. They are just guessing and doing a damn poor job of it.
Reply With Quote
  #5  
Old 02-10-2012, 10:30 AM
95powersmoker's Avatar
BOMBARDIER

   
View Member's Albums

Default

If your fuel bowl was empty, sounds like a fuel issue...

Have you tried switching tanks and all that?

Last edited by 95powersmoker; 02-10-2012 at 10:37 AM..
Reply With Quote
  #6  
Old 02-10-2012, 11:15 AM
Newbie

   

Default

I'm doing just that right now!!! I'm pulling my truck out of there now....

---AutoMerged DoublePost---

Fuel issue resolve with new pump. I have fuel , oil pressure still no start!

Last edited by Bully; 02-10-2012 at 11:15 AM.. Reason: Automerged Doublepost
Reply With Quote
  #7  
Old 02-10-2012, 11:19 AM
95powersmoker's Avatar
BOMBARDIER

   
View Member's Albums

Default

My apologies, I skipped over the fuel pump replaced...

Need to get it on a scanner and watch your ICP and DC% while cranking...

A quick and dirty test would be to take the valve covers off and watch the injectors while cranking. There should be oil coming from the spill spouts. You said the injectors weren't firing but this will confirm or deny that.
Reply With Quote
  #8  
Old 02-16-2012, 07:25 PM
Newbie

   

Default

Update still no fire on the old girl.... Going through the wiring harness wire per wire... To see if something is burnt. Found a 10 amp fuse blown out try to replace it and it did it again . Any suggestions ?
Reply With Quote
  #9  
Old 02-16-2012, 07:26 PM
95powersmoker's Avatar
BOMBARDIER

   
View Member's Albums

Default

Which fuse? Clearly something on that circuit causing it to pop the fuse...
Reply With Quote
  #10  
Old 02-16-2012, 08:24 PM
u2slow's Avatar
Diesel Enthusiast

   

Default

Is your hpop building pressure? (best checked with a 3500psi mechanical gauge)

Is there oil in the hpop reservoir?

There is a de-aeration valve in the timing cover on the early ones that can work loose dump most of the oil your lpop is trying to pump.

u2slow's Sig:93 W250 Club 6BTA/5spd/3.54....3" lift, Dana 80 swap, shackle flipped 2ndgen leafs, HX35 & 5x.012 sticks, 4" pipe, 33"s on 3rdgen wheels
84 Ramcharger D250[project]... 6BT/5spd/3.07...
90 D250 6BT/5spd/3.54[/size]
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 01:19 PM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check