Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Ford Powerstroke > Ford Powerstroke 94-98 7.3L
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

Ford Powerstroke 94-98 7.3L Discussion of 94-98 7.3 Liter Ford Powerstroke Turbo Diesels

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


That happened to mine. First time it was a fuse. Second time the oil pressure regulator had melted so. And i would check the crankshaft sensor if all else fails.... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #11  
Old 02-23-2011, 08:25 PM
97strokerHD's Avatar
Diesel Fan
Status: Stage 1s. Think so!

   
View Member's Albums

Default

That happened to mine. First time it was a fuse. Second time the oil pressure regulator had melted so. And i would check the crankshaft sensor if all else fails.
Reply With Quote
  #12  
Old 02-26-2011, 04:37 AM
cableneff's Avatar
Diesel Fan
Status: Drillers go Deeper

cableneff cableroughneff
   
Default

ok i will check the crankshaft sensor, will update results on tuesday.
Reply With Quote
  #13  
Old 02-26-2011, 12:22 PM
95powersmoker's Avatar
BOMBARDIER

   
View Member's Albums

Default

Camshaft sensor.... CPS (Camshaft positioning sensor)

And yes, I believe your truck should have started with those pressure numbers.

95powersmoker's Sig:
1995 F-250 Powerstroke, auto, 4x4
Gauges, Tymar Intake, SD dual exhaust, TW chip, Stage 1's

2000 F-250 SC/SB Powerstroke 4x4, Auto FOR SALE
Reply With Quote
  #14  
Old 03-02-2011, 06:22 PM
cableneff's Avatar
Diesel Fan
Status: Drillers go Deeper

cableneff cableroughneff
   
Default

ok i just put a new cps from the ford house on the truck and nothing... still wont start so im going to pull the drivers side valve cover and check for oil passing the injectors, can't be to many things left to change or check or is there...
Reply With Quote
  #15  
Old 03-02-2011, 08:23 PM
95powersmoker's Avatar
BOMBARDIER

   
View Member's Albums

Default

The truck cranks but wont fire? Does smoke come out the tailpipe when you crank? You said it started on Ether, does it stay running with ether or immediately die? How are the batteries? Can you check your HPOP Res and stick a straw or something in there to see how far down the oil is?
Reply With Quote
  #16  
Old 03-03-2011, 02:52 PM
cableneff's Avatar
Diesel Fan
Status: Drillers go Deeper

cableneff cableroughneff
   
Default

thats correct it will turn over but wont start. will die right away after eather shot and the hpop resevior is full. both batteries are pretty new and on a charger.
Reply With Quote
  #17  
Old 03-03-2011, 05:50 PM
95powersmoker's Avatar
BOMBARDIER

   
View Member's Albums

Default

If you open the Fuel filter housing in the middle of the valley, is it full of fuel?
Reply With Quote
  #18  
Old 03-05-2011, 01:03 PM
cableneff's Avatar
Diesel Fan
Status: Drillers go Deeper

cableneff cableroughneff
   
Default

yes, i have taken the fuel filter cap off a couple of times just to check the fuel level and its good and full, even went so far as to turn truck over and verify that fuel is coming in to the bowl.

---AutoMerged DoublePost---

I need to know if there is a way to check if oil is getting to the injector, like can i pull the injector and turn the engine over and look to see oil in the opening or something.

Last edited by cableneff; 03-05-2011 at 01:03 PM.. Reason: Automerged Doublepost
Reply With Quote
  #19  
Old 03-05-2011, 01:14 PM
95powersmoker's Avatar
BOMBARDIER

   
View Member's Albums

Default

Your oil in the case is full correct?

Have you tried unplugging the ICP sensor and trying to start it?

Is there anybody near you willing to let you try a known good IDM?

Last edited by 95powersmoker; 03-05-2011 at 01:23 PM..
Reply With Quote
  #20  
Old 03-05-2011, 06:16 PM
cableneff's Avatar
Diesel Fan
Status: Drillers go Deeper

cableneff cableroughneff
   
Default

yes the oil in the truck is at the correct level, hpop is full, i just put a new icp sensor on the truck and i've just tried to start it unpluged and nothing.. Note..i can hear the injectors opening after a few seconds which i feel is a good sign because that means the hpop is building pressure, checked for smoke at the stack while turning engine over, no smoke... just loosened fuel line going to pass side head and got fuel, is there some way the injectors are not getting the fuel to them? could an o-ring fail and cause this problem...i havent noticed any change in the oil level since ive changed it..

---AutoMerged DoublePost---

as far as the IDM goes i dont really think i can get one short of buying one off the web. If it has failed would the injectors still open..

Last edited by cableneff; 03-05-2011 at 06:16 PM.. Reason: Automerged Doublepost
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 11:45 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check