Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Ford Powerstroke > Ford Powerstroke 03-07 6.0L
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

Ford Powerstroke 03-07 6.0L Discussion of 6.0 Liter Ford Powerstroke Turbo Diesels
Sponsored by Sinister Diesel
Click Here


Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


so here is the story, i was getting ready to head to work one morning and my truck would crank and crank but no start. i checked all the fuses but everything was perfect. it was fine when i parked it so i was baffle. ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-11-2010, 02:16 PM
Diesel Fan

   

Default 05 6.0 NO START!

so here is the story, i was getting ready to head to work one morning and my truck would crank and crank but no start. i checked all the fuses but everything was perfect. it was fine when i parked it so i was baffle. well i got a ride to work and when i got home it fired right up and then died immediately. then i tried again and it fired right up and has been running great for the last 2 months. yesterday i was driving along and it just died, still cranks and everything. the tach still works, glow plug light cycles, and everything seems normal but still no start. any ideas? im lost. any input would be greatly appreciated. thanx
Reply With Quote
  #2  
Old 09-11-2010, 03:42 PM
Mdub707's Avatar
BOMBARDIER
Status: 6.0 powerstroke masochist

   

Default

My quick guess is either ICP sensor or FICM issues. Check this out and see what you think... Diesel Technician Society

---AutoMerged DoublePost---

Also I know the article says for 03/04 trucks, the only difference is the blurb about the oil doesn't really concern you since 05+ trucks the ICP sensor is located on the passenger side valve cover. The issue with the starting problems still concerns you though. Have you tried to get codes read on it? It might still have some codes even without a check engine light.

Mdub707's Sig:


Last edited by Mdub707; 09-11-2010 at 03:42 PM.. Reason: Automerged Doublepost
Reply With Quote
  #3  
Old 09-12-2010, 07:44 PM
Diesel Fan

   

Default

ok those were the same guesses that i had. any idea how to test them? i think my icp sensor is right in the valve cover. is that correct? if not does anyone have a picture? thanks
Reply With Quote
  #4  
Old 09-13-2010, 11:49 AM
Mdub707's Avatar
BOMBARDIER
Status: 6.0 powerstroke masochist

   

Default

If you have an 04, I think it's in the back of the motor below the turbo. Should have three wires going to it. Should only be two things back there, your ICP sensor and your IPR valve.

FICM testing is relatively easy to do. Just google search 6.0 powerstroke FICM test repair. It will tell you how to test it and how to fix it if you can solder.
Reply With Quote
  #5  
Old 09-13-2010, 05:08 PM
biged681985's Avatar
BOMBARDIER
Status: getting back to my old self

xbox is gay biged681985
   
View Member's Albums

Default

03 is the only one the icp was on the back of the motor by the ipr. 04 and up go through pass valve cover

biged681985's Sig:99 dodge = broken, and waiting to be under the knife
98 dodge = let out in the pasture to die
06 ford = waiting to be fixed, or have a 12v transplant
05 vw Passat tdi. running strong
00 dodge = 330k ready to see what it has in her
black sheep = details coming soon

Big Ed's Diesel Service
Reply With Quote
  #6  
Old 09-14-2010, 01:05 AM
Diesel Fan

   

Default

ok well i have an 05 and it is in the valvecover. i google that test/repair and couldnt find anything that applied to my situation. any other ideas?
Reply With Quote
  #7  
Old 09-14-2010, 05:55 PM
Mdub707's Avatar
BOMBARDIER
Status: 6.0 powerstroke masochist

   

Default

The FICM test and repair?? You couldn't find how to do it, or you just don't think that's your problem?

BigEd - some early 04's had them too.
Reply With Quote
  #8  
Old 09-16-2010, 12:44 AM
Diesel Fan

   

Default

ok well i found the problem.the hpop exploded and took out the regulator with it. goody. not cheap. thanks for all your help.
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 04:36 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check