Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Ford Powerstroke > Ford Powerstroke 03-07 6.0L
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

Ford Powerstroke 03-07 6.0L Discussion of 6.0 Liter Ford Powerstroke Turbo Diesels
Sponsored by Sinister Diesel
Click Here


Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


I have a 2004 Ford F-250 Powerstroke 6.0L and went to work the other day I shut my truck off and it hasnt started since. I replaced the fuel pump relay and the cam shaft positioning sensor and all it does is turn over. Any ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-03-2010, 12:19 AM
jpick782's Avatar
Diesel Fan

   
View Member's FaceBook Profile

Default 04 F250 6.0 Won't Start

I have a 2004 Ford F-250 Powerstroke 6.0L and went to work the other day I shut my truck off and it hasnt started since. I replaced the fuel pump relay and the cam shaft positioning sensor and all it does is turn over. Any Idea's?
Reply With Quote
  #2  
Old 05-03-2010, 12:29 AM
Mdub707's Avatar
BOMBARDIER
Status: 6.0 powerstroke masochist

   

Default

Is there any reason you decided to replace those? Any codes? How many miles, any programmers or anything else on the truck?? More details...

Mdub707's Sig:

Reply With Quote
  #3  
Old 06-01-2010, 04:08 PM
ATX6132's Avatar
Diesel Enthusiast
Status: Strokin Fool

nuckingfuts6
   
Default

check ipr valve that was my reason..

ATX6132's Sig:
04 F-350 6.0 Dually-SCT Tuned SinisterEgrDelete,SinisterCoolant filt
5in. to 7in.Blacktip,CFM+,AirRaid intake,Zoodad
RockStars,SmokedRecon,Thanks TruckSourceDiesel!!!
Reply With Quote
  #4  
Old 06-08-2010, 10:33 PM
Karls03's Avatar
BOMBARDIER
Status: I hate Edge so much, I quit using Edge shaving gel!

   
View Member's Albums

Default

Checking the fuses got my 03 running again.

Karls03's Sig:SRL + 4" exhaust = 13.89@96.68

Reply With Quote
  #5  
Old 06-08-2010, 11:08 PM
FRIDAY88's Avatar
BOMBARDIER
Status: BLACK PHANTOM

Cody Friday
   
View Member's Albums

Default

sometimes CEL wont be on display scan truck and get codes if any, also need symptoms of how it was running before shut off,, I agree with Mdub707 more details

FRIDAY88's Sig:2010 6.4l stroker aka the Black Phantom AFE exhaust AFE intake With EDE Filter and intake elbow upgrade EDE tow power atmosphere turbo Spartan programmer Rudy's Diesel EGR Delete and Intake Elbow Rudy's Custom Uppipes 33x12.50/18 Toyo MT
Reply With Quote
  #6  
Old 06-08-2010, 11:09 PM
Rustin's Avatar
Banned
Status: Do you really want to know my STATUS?

Rustin Hawver
   
Default

Is your fuel pump working? PM me it might be something simple.

Last edited by Rustin; 06-08-2010 at 11:10 PM.. Reason: Not enuff content
Reply With Quote
  #7  
Old 06-12-2010, 01:46 AM
Newbie

   

Default

on my truck ac compressor was causing engine to turn over too slow.try removing belt and see if it starts.
Reply With Quote
  #8  
Old 08-06-2010, 02:52 PM
jpick782's Avatar
Diesel Fan

   
View Member's FaceBook Profile

Default

I have done a lot to the truck and it still is not running. Here is the list I changed my FICM got the truck running for a little while then after changing the EGR cooler to a delete kit the truck stopped running again. I changed the IPR valve TWICE hoping it was the problem and the truck would start but only run about 10 minutes. It is like when the truck runs and the oil gets warm and thins out the truck shuts down. I am still not throwing any codes but have a ford mechanic friend that was running the computer on the truck so we could test the High pressure system we got 800 PSI on one side and 1000PSI on the other. We got the truck started and after a few minutes it ran great after we shut it down I asked him to try and start it again and it wouldnt it would only get 350 psi. I did an oil change and got the truck to run for 45 minutes sitting there at Idle then it shut down. The next day I took it out and it ran for about 5 minutes then I had to be towed home. I have the engine torn down now and I tested the High pressure system with air for leaks we heard something on both sides so put some oil dye in the system and put the air to it again. I have what looks like two leaks where the high pressure rail connects to the fuel injector. One on each side right the closest to the firewall. So just about everything has been replaced including the Cam sensor so any ideas from anyone because I have stumped the Ford Mechanic.
Reply With Quote
  #9  
Old 07-12-2012, 04:15 PM
Newbie

   
View Member's Albums View Member's Youtube Account

Up at wits end

i have a power stroke pro if you want to call and hit him with what you did and what it's not doing he will solve i am sure.
his name is Chris he works at Diesel Doctors in Georgetown his number is
Hope this helps
Cheers


I removed the number for a couple reasons. You have no posts here and offered no help other than getting your buddy some side work who isn't even on the site or a paying sponsor. Another reason is, your buddy probably doesn't want all the spam phone calls he'll be getting with his number out in the interwebs.

Thanks, Mdub707.

Last edited by Mdub707; 07-18-2012 at 11:53 AM..
Reply With Quote
  #10  
Old 07-12-2012, 05:09 PM
1964Horseman's Avatar
Diesel Fan
Status: Tryin' to learn something new every day!

   
View Member's Albums

Default

You will definitely have to fix your high pressure oil leaks at the injectors first. The original kits can be had from the stealership for about $5.00 each.
Then do another pressure test and see if there are anymore leaks. Understand that the leak does not have to be very big. It is a pressure issue and not volume. Without a min of 500psi during crank, injectors will not fire and you will probably eventually throw icp, ipr or various injector codes unfilled the leaks are fixed.

---AutoMerged DoublePost---

Damn auto correct! That was supposed to say the "O ring" kits.

Last edited by 1964Horseman; 07-12-2012 at 05:09 PM.. Reason: Automerged Doublepost
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 01:14 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check