89 F350 No Start Help Please!!!! - Diesel Bombers
Diesel Bombers
Go Back   Diesel Bombers > Ford Powerstroke > Ford 83-94 6.9 and 7.3L General
Search


Ford 83-94 6.9 and 7.3L General Discussion of 83-94 6.9 and 7.3 Liter Ford Diesels

I have a 89 F350 with the 7.3 idi in it. Truck has been running great no problems at all. Went out to start the yesterday and it it fired up ran for about 15sec and died and will not start back. I tried a ... JOIN NOW TO REMOVE TRACER

89 F350 No Start Help Please!!!!

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-02-2012, 11:14 AM
Newbie

   

Default 89 F350 No Start Help Please!!!!

I have a 89 F350 with the 7.3 idi in it. Truck has been running great no problems at all. Went out to start the yesterday and it it fired up ran for about 15sec and died and will not start back. I tried a shot of ether(which i have never had to do) and still nothing. Glow plugs are new and the gp controller is new i did verify the gp and gp controller are working it will spin over good but will not start. No smoke out the tail pipe
Reply With Quote
  #2  
Old 11-02-2012, 11:37 AM
Newbie

Ziggyfresh
   
View Member's FaceBook Profile

Default

Have you checked your fuel level? Look for leaks in the return lines/caps on the injectors, could be a drainback issue. Lift pump might have went, check your oil level to make sure your crankcase isn't full of diesel. But first make sure you have diesel in your tanks, if you don't, fill 'er up and be prepared to crank it over for a while.
Reply With Quote
  #3  
Old 11-02-2012, 12:05 PM
Newbie

   

Default

The rear tank is full i switched to it the night before after filling it up. I know the front tank is near empty. No fuel in the crank case
Reply With Quote
  #4  
Old 11-02-2012, 12:09 PM
Newbie

Ziggyfresh
   
View Member's FaceBook Profile

Default

I would check the FSV to make sure it switched over fully to the rear tank, also make sure there isn't a broken pickup tube in the rear tank
Reply With Quote
  #5  
Old 11-02-2012, 02:07 PM
Newbie

   

Default

It was running fine the night before after switching tanks. and i know the front tank still has somne fuel in it its just low
Reply With Quote
  #6  
Old 11-04-2012, 01:21 PM
Newbie

   

Default

like wil ziggy said check for air, and if not, try a fuel filter, i know my 94 is a bear to start if the filter is clogged, also you said the rear tank is full, did you just fill it up? was it sitting in there for a while?
Reply With Quote
  #7  
Old 11-22-2012, 10:47 AM
Kalashnikov's Avatar
Diesel Fan

   

Default

Sounds like either lift pump died or the fuel filter is clogged.

I would chnage the filter and if that doesn't help pull of the top part of the line from te lift pump to the fuel filter housing and check for fuel flow.

I had the same thing happen to my 93 idi turbo and it was the fuel filter even though it was just running fine.

Kalashnikov's Sig:89 F350 CC 7.3 IDI, 71 Kaiser Jeep M818 Cummins NHC 250, 68 Mack M123A1C Cummins 300V8
Reply With Quote
 
 
 
Reply



Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 02:57 AM.

Copyright And Legal Notice Links Of Interest

Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check


Diesel Bombers Dodge Cummins Forum Section Diesel Bombers Ford Powerstroke Forum Section Diesel Bombers Chevy GMC Duramax Forum Section