Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Chevy/GMC Duramax > Chevy/GMC Truck and Duramax Turbo Diesel Forum
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

Chevy/GMC Truck and Duramax Turbo Diesel Forum Discussion of General Topics related to All Chevy and GMC Trucks as well as the Diesels in them

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


Have a 2002 GMC 2500 Duramax. Just put all new injectors in it. Drove 40 miles out of town and it started losing power. If you let off the accelerator it will gain a bit of power and when you try and accelerate again it ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-06-2013, 09:07 AM
Newbie

   

Default Injector Issues

Have a 2002 GMC 2500 Duramax. Just put all new injectors in it. Drove 40 miles out of town and it started losing power. If you let off the accelerator it will gain a bit of power and when you try and accelerate again it does a nosedive and you can only get up to 20 mph. I was told it was the prime pump. Anyone have any answers? All help is greatly appreciated
Reply With Quote
  #2  
Old 06-06-2013, 09:54 AM
MillerBoyzDiesel's Avatar
Diesel Wrench

   
View Member's Albums

Default

Did you replace fuel filter?
Reply With Quote
  #3  
Old 06-06-2013, 10:22 AM
Newbie

   

Default

Yes I have already replaced fuel filter
Reply With Quote
  #4  
Old 06-06-2013, 11:32 AM
MillerBoyzDiesel's Avatar
Diesel Wrench

   
View Member's Albums

Default

Might have a hose collapsed around the filter housing to ficm or the lines that come in on the driver side could be damaged where the black nylon braided part is. You wont be able to see any damage externally but they have a liner inside that can kink when the lines get bent over out of the way during injector job. If you can check vacuum on the system see if you have a restriction, if not you can use clear hose at the filter housing to check for air entering somewhere.
Reply With Quote
  #5  
Old 06-06-2013, 02:10 PM
Newbie

   

Default

Thanks for the info lets see what that does
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 01:16 PM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check