Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Chevy/GMC Duramax > Chevy/GMC Truck and Duramax Turbo Diesel Forum
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

Chevy/GMC Truck and Duramax Turbo Diesel Forum Discussion of General Topics related to All Chevy and GMC Trucks as well as the Diesels in them

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


2003 chevy duramax 2500HD 4x4 150K miles, STOCK. i just replaced my glow plugs and fuel filter and it seemed perfect for two days, now its turning over too long again. mainly cold start. whats next? glow plug relay? glow plug controller? help please. any ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-05-2013, 04:31 PM
Newbie

   

Default 2003 chevy duramax cold start problem

2003 chevy duramax 2500HD 4x4 150K miles, STOCK. i just replaced my glow plugs and fuel filter and it seemed perfect for two days, now its turning over too long again. mainly cold start. whats next? glow plug relay? glow plug controller? help please. any input would help at this point. thanks
Reply With Quote
  #2  
Old 02-06-2013, 09:03 AM
Diesel Fan
Status: B.A.M.F

   

Default

What's is the temperature when you try to start?
Reply With Quote
  #3  
Old 02-07-2013, 10:26 PM
Newbie

   

Default

ranges from 30-40 degrees F. since i replaced the glow plugs and fuel filter it starts but still turns over longer than normal. and even when warm still turns over a little too long. could it be injecters? or glow plug relay? i primed the fuel filter and messed with the bleeder. im pretty sure i worked all the air out of the lines. thanks
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 04:14 PM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check