Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Chevy/GMC Duramax > Chevy/GMC 6.2L and 6.5L
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

Chevy/GMC 6.2L and 6.5L Discussion of Chevy and GMC Trucks with 6.2L and 6.5L Diesel Engines

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


My truck wiill start and run perfect for about 10 seconds then stall , and it wont start till it sits for a while. It started a couple weeks ago, it would run fine, then stall. sometimes it would run good for a couple days, ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-05-2011, 06:13 PM
Diesel Fan

   

Default 95 GMC 6.5 runs for 10 sec. then stalls and wont start

My truck wiill start and run perfect for about 10 seconds then stall , and it wont start till it sits for a while. It started a couple weeks ago, it would run fine, then stall. sometimes it would run good for a couple days, then start stalling, usually it would start right back up. I changed the fuel filter, put a different (used) lift pump on, cleaned grounds, recently replaced the PMD, and relocated it to the bumper, new OPS. Injector pump is about 2 years old OEM. Batteries tested good, I can hear the lift pump running when I turn the key on, but it sounds different. I am getting fuel to the filter when cranking. Im starting to think I should do the Cummins conversion. Any and all help with this problem would be greatly appreciated. thanks in advance
Reply With Quote
  #2  
Old 03-05-2011, 10:17 PM
Diesel Fan

   

Default

You might consider the lift pump relay as part of the problem. If its coil is weak or its points burned or corroded you will get erratic operation. The relay in my '94 td is only in use during the starting cycle but I believe the relay in the '95+ is closed at all times. It's about a $20 part at O'Reilly.
Reply With Quote
  #3  
Old 03-06-2011, 12:40 AM
Crazy's Avatar
Diesel Bomber
Status: Gotter love te smell of diesel

   
View Member's Albums

Default

first thing start with is OSP and LP test

it sound like bad PMD

you said you clean grounds was that just battery ground if so you miss alot at back right of engine their are more ground and straps make sure they are clean and good make sure the straps going from and to the firewall and to the frame and are in good shape

If you want do cummins that just wast of money going cost you you most likey fine d-max for what going cost you put cuimmins in

Crazy's Sig:Traded for 94 F-350 turbo blow the motor up little red
1997 3500 Ext Cab 2 Wheel Drive 300,000 plus miles New Trans with up grades for towing Rebuild Rear end 4:11 with
new axles,new injectors, 4" Exhaust , 5" tip, PMD Moved to front Bumper TM 18psi boost,,new LP,boost,EGT and trans gauges and Max E Tork T-Series

Last edited by Crazy; 03-06-2011 at 12:42 AM..
Reply With Quote
  #4  
Old 03-06-2011, 01:39 AM
Diesel Fan

   

Default

I cleaned the the grounds at back of intake,straps, and battery. Any others I need to be checking? How is the lp grounded? I also noticed I can hear something Buzzing in the dash, not sure that its related though.
Reply With Quote
  #5  
Old 03-06-2011, 11:09 PM
Crazy's Avatar
Diesel Bomber
Status: Gotter love te smell of diesel

   
View Member's Albums

Default

there should be ground wire on top of the pump for the PMD

Could be bad PMD

Injector pump is about 2 years old OEM. Batteries tested good, I can hear the lift pump running when I turn the key on, but it sounds different. I am getting fuel to the filter when cranking. Im starting to think I should do the Cummins conversion. Any and all help with this problem would be greatly appreciated. thanks in advance

Just because hear LP running doesn't mean it working right i would put 12v right to it and see if you get fuel out at water drain hose
Reply With Quote
  #6  
Old 03-07-2011, 11:09 PM
Diesel Fan

   

Default

If the lift pump relay coil is weak, when it tries to run the pump (which draws a lot of current) the points in the coil will open and close rapidly causing the humming sound you hear decreasing the current to the pump and decreasing, if not stopping the pump, intermitantly, decreasing the fuel flow. The relay can be tested if you don't want to replace it.
Reply With Quote
  #7  
Old 03-08-2011, 06:00 PM
Diesel Fan

   

Default

I ordered a new LP relay today, should be in tomorrow, I'll let you know how I make out.

---AutoMerged DoublePost---

I installed a new LP relay today , still the same . Runs for a few seconds then shuts off and wont start for about 10-20 minutes. I have a new PMD ordered for tomorrow. Hopefully that will do it.

Last edited by witemanfromhil; 03-08-2011 at 06:00 PM.. Reason: Automerged Doublepost
Reply With Quote
  #8  
Old 03-08-2011, 09:55 PM
Diesel Fan

   

Default

Sorry to hear the relay didn't solve your prob. What kind of temperatures are you having in central PA when you start your truck?
Reply With Quote
  #9  
Old 03-08-2011, 10:18 PM
Diesel Fan

   

Default

Its getting into the high teens at night. I keep my truck in a heated garage. But now that you mentioned it, I left my truck outside one night and it wouldnt start in the morning, it was a very cold morning(6degrees). I think I may have a bad GP or 2. Would this make my truck act like this?
Reply With Quote
  #10  
Old 03-08-2011, 10:31 PM
Crazy's Avatar
Diesel Bomber
Status: Gotter love te smell of diesel

   
View Member's Albums

Default

ya it could if your glow plugs not working
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 04:20 PM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check