Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Chevy/GMC Duramax > Chevy/GMC 6.2L and 6.5L
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

Chevy/GMC 6.2L and 6.5L Discussion of Chevy and GMC Trucks with 6.2L and 6.5L Diesel Engines

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


NEED HELP BAD!! Just recently had problems with my truck shutting down.Checked fuel PSI,checked fuel return (made sure there was no backpressure)cracked injecter line,no fuel after cranking thruogh two battery charges.solonoid opening up when going to start (PMD Operates solonoid Right?) I got deperate after ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-21-2011, 12:21 PM
Diesel Fan

   

Default 1996 chevey turbo dsl wont start

NEED HELP BAD!!
Just recently had problems with my truck shutting down.Checked fuel PSI,checked fuel return (made sure there was no backpressure)cracked injecter line,no fuel after cranking thruogh two battery charges.solonoid opening up when going to start (PMD Operates solonoid Right?)
I got deperate after having a few friends looking at it so I ripped down and replaced with new injection pump.I cracked injector and started engine witout intake manfld,it started and I QUIKLY shut down and reassembled (took around three days to get back to it)I tried starting again, No fuel to injecters!!! I primed fuel system and checked fuel PSI and flow to the inlet line of the pump and solonoid is activating.Ihave a brand new ijecter pump and PMD.What else can I do or check inorder to narrow down the problem???
Any help will be appreciated I AM GOING MAD FELLOWS!!!
J.B.
Reply With Quote
  #2  
Old 02-21-2011, 04:47 PM
ricansdiesel's Avatar
Diesel Fan

   

Default

did you check your lift pump? under the truck on driver's side on frame rail by the door.see if you have power going to it by disconnecting the plug and putting 12v directly to it. it may also be that you still have air in the system. i'm pretty sure some of the other members will chime in on this too...good luck.

ricansdiesel's Sig:1995 gmc sierra k2500, xc/lb, 5spd, new 6.2/6.5,relocated pmd,ops relay mod,mechanical wastegate controller,boost gauge.more mods and upgrades as the wife allows.
Reply With Quote
  #3  
Old 02-21-2011, 09:15 PM
Crazy's Avatar
Diesel Bomber
Status: Gotter love te smell of diesel

   
View Member's Albums

Default

X2 what ricansdiesel said

Crazy's Sig:Traded for 94 F-350 turbo blow the motor up little red
1997 3500 Ext Cab 2 Wheel Drive 300,000 plus miles New Trans with up grades for towing Rebuild Rear end 4:11 with
new axles,new injectors, 4" Exhaust , 5" tip, PMD Moved to front Bumper TM 18psi boost,,new LP,boost,EGT and trans gauges and Max E Tork T-Series
Reply With Quote
  #4  
Old 02-22-2011, 02:16 PM
Diesel Fan

   

Default

Yes,when I turned the key, everything was working,I cracked the top of filter to prime
it and when you turn on the key,fuel flowes out from filter.I also checked fuel flow through the bleeder line connected to that cooling housing.fuel shutoff solenoid isnew and working.
I did notice that when I did a load test on the batteries and I noticed they dropped down to 9 volts.Ihave heard that if some diesel systems (electronic) voltage drops at a value lower than ten volts,will not allow the system start mode.I did meter the input to
the pmd that supply the 12vlts to the injection pump solenoid that allows fuel to flow to the output to the injecters and was reading only 300mv when I cranked it over which is suspiciouse to me.Before this happend, I had the truck stall but it started it,then my son used the truck with my wife and the truck died at a target store.The batteries were dead so my son went nextdoor and purchased 2 760 cranking amp batteries from wallmart.He did start the truck when he installed them,but when the truck sat for 3 days,I went to start it,and it stutterd and smoked then shut down.Icould not start ever since, so after putting in a new pump and pmd module and having no luck (charging the batteries after every battle),
I think my suspicians about the battery voltage may not be far off. I checked all the outputs oil psi sensor,cutoff solenoid,the outputs from the pcm to the pmd,and the crank sensor (seen the AC pulses from sensor when it cranked).
Please let me know what you gentleman think,and I will let you know what happens
when I change out the batteries.I still want your opinions while I go through this process

Thanks again guys KEEP THE INFO COMING1
Big Joe
Reply With Quote
  #5  
Old 02-22-2011, 05:04 PM
Crazy's Avatar
Diesel Bomber
Status: Gotter love te smell of diesel

   
View Member's Albums

Default

well glow plug relay will draw down power

One thing to try is disconnect OS filter from the bad of pump and just plug main harness in and gave try

have check all your glow plugs and check and clean all the ground and is SEL saying on after key is on for more then min

Yes these truck got have cracking speed to start

Also was thinking maybe bad CPS (Crankshaft Position Sensor) not sure how test

Last edited by Crazy; 02-22-2011 at 05:09 PM..
Reply With Quote
  #6  
Old 02-22-2011, 10:45 PM
Diesel Fan

   

Default 6.5 will not start

Tried high cranking batteries and checked fuel pump solenoid stays on after key is turned on. Still no fuel to fuel injecters!! I followed GMs testpoint flow chart and tested the points on the PMD cable and one of them was not outputting,and manual stated it was bad fuel pump.I cant believe this pump I put in is bad!! I also disconnected the optic sensor and tried starting (nothing)

Tomorrow I will check lift pump again as well as put a gauge on inlet line to check the psi
from lift pump. Does anyone know where I can get a brand new injection pump at a good price ???? Please let me know! I think I am facing that grim reality that this pump is bad!

ANYBODY HAVE ANY SUGGESTIONS AFTER READING MY POST?? I am running out of options. I sure hate to relace this pump a third time and find out that it was somthing I may have overlooked.
Thanks,Big Joe
Reply With Quote
  #7  
Old 02-23-2011, 08:10 AM
Crazy's Avatar
Diesel Bomber
Status: Gotter love te smell of diesel

   
View Member's Albums

Default

Think try other PMD first off before i buy other pump PMD are know for 99% of no start
Reply With Quote
  #8  
Old 02-23-2011, 08:20 PM
ricansdiesel's Avatar
Diesel Fan

   

Default

hey big joe,try diesel care and performance in memphis tn. the couple of times i've talked to them,they seem pretty knowledgeable.i also second crazy's post of checking the pmd. i have heard horror stories about them.
Reply With Quote
  #9  
Old 02-23-2011, 08:48 PM
Crazy's Avatar
Diesel Bomber
Status: Gotter love te smell of diesel

   
View Member's Albums

Default

it also could be bad ECM
Reply With Quote
  #10  
Old 02-24-2011, 07:29 PM
Woody35's Avatar
Diesel Bomber
Status: Lovin the KOJO Tune

BigWoody35
   
Send a message via AIM to Woody35 Send a message via Yahoo to Woody35 View Member's Albums View Member's Youtube Account

Default

truck isnt going to start with unplugged optic sensor. have you checked the fuel shutoff soleniod. if you take it out it and the truck fires you need to replace it

Woody35's Sig:1997 Chevy K1500 4X4 EC/SB L56 6.5TD/4L80E
KOJO Tune, GM-8 Turbo gated @ 15 psi, 2100 PSI Pop Pressure Bosch Injectors,
Bosch Duratherm Glowplugs, Steel Braided Oil Cooler Lines,Relocated D-Tech PMD,Tekonsha Voyager Brake Controller
Autometer Gauges, ARP Headstuds, K47 Air Box , Flowmaster Crossover & 4 Inch Diamond Eye Exhaust
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 06:11 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check