Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Chevy/GMC Duramax > Chevy/GMC 6.2L and 6.5L
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

Chevy/GMC 6.2L and 6.5L Discussion of Chevy and GMC Trucks with 6.2L and 6.5L Diesel Engines

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


Hi, I have a 2000 chevy 6.5L TD and I am currently stuck limited to 40-50 mph driving through the desert ( pedal to the floor). Turbo was acting erratic after coming off a mountain, kicking on and off and getting to 0 psi way ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-18-2013, 06:49 PM
Newbie

   

Beer Stuck going 40 in NM desert!

Hi, I have a 2000 chevy 6.5L TD and I am currently stuck limited to 40-50 mph driving through the desert ( pedal to the floor). Turbo was acting erratic after coming off a mountain, kicking on and off and getting to 0 psi way too quickly. Now it won't kick on at all and check engine light is on and I'll bet money it is the turbo sensor. Someone please tell me I'm right and it's not the PMD or IP. Got the turbo checked before I left so it may just be a loose connection or sensor. Air filter and fuel filter are both clean. Trying to make it to a gig in Albuquerque tonight, don't want to be stranded!
Reply With Quote
  #2  
Old 07-19-2013, 11:31 AM
racer55's Avatar
Diesel Bomber
Status: familiar with the 6.5 and then some

   

Default

Sounds like the boost sensor or vac pump failed but without trouble codes I can't say for sure.

DO NOT push hard making black smoke out the exhaust-something will melt down-keep EGT's below 1200F.
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 02:53 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check