Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Dodge Cummins > 6.7 Liter Dodge Cummins 07.5-12
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

6.7 Liter Dodge Cummins 07.5-12 Discussion of 6.7 Liter Dodge Cummins Diesels

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


I have a 2012 6.7 with a smarty Jr on the 40hp tune, 5" turbo back, sinister egr delete kit, and air raid intake.. for some reason if I give it half throttle it seems to work fine.. but at full throttle it acts like ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 03-05-2013, 10:11 PM
Newbie

   
View Member's Albums

Default fully deleted 2012 6.7 defueling

I have a 2012 6.7 with a smarty Jr on the 40hp tune, 5" turbo back, sinister egr delete kit, and air raid intake.. for some reason if I give it half throttle it seems to work fine.. but at full throttle it acts like its defueling. Happens at about 2500 rpm.. any suggestions on what this may be?
Reply With Quote
  #2  
Old 03-06-2013, 09:41 AM
MillerBoyzDiesel's Avatar
Diesel Wrench

   
View Member's Albums

Default

whens the last time you changed fuel filter?
Reply With Quote
  #3  
Old 03-06-2013, 10:04 AM
Newbie

   
View Member's Albums

Default

It only has 10000 miles on the truck and about 5000 on the fuel filter but honestly I didn't even think of the fuel filter being clogged up.
Reply With Quote
  #4  
Old 03-06-2013, 10:09 AM
cummins05's Avatar
Diesel Fan
Status: Bring on the mods!!

rccanamrider
   
View Member's Albums

Default

I would say its your traction control, mine does that also there should be a button beside yer tow/haul button. Its kills the power cuz it starts spinning. Might not be whats wrong with yers but thats what mine does till i turn that off. Hope this helps ya

cummins05's Sig:2012 Ram Laramie
So far the the mods done are,H&S mini maxx fully deleted,5 inch diamond eye straight exhaust with 8 inch tip,tinted windows,bed cover,2 inch leveling kit.
2006 jeep liberty diesel, full torque eco tune by green diesel and trans tune, 2 inch lift with custom wheels and bigger tires.
Reply With Quote
  #5  
Old 03-06-2013, 11:50 AM
Newbie

   
View Member's Albums

Default

With traction control on.. does your truck do it at 70mph and higher?? Because that's when i notice it the most.. when passing someone at a higher speed.
Reply With Quote
  #6  
Old 03-06-2013, 04:51 PM
cummins05's Avatar
Diesel Fan
Status: Bring on the mods!!

rccanamrider
   
View Member's Albums

Default

No as long as im not spinning its fine! Must be something else. Does the smarty junior have any setting on the programming to make it defuel? Like to much boost or egt or something like that? I have never had a junior.
Reply With Quote
  #7  
Old 03-11-2013, 01:59 AM
Diesel Fan

   

Default

If you have a mm you can look at fuel rail pressure, make sure your not running out of fuel or loseing fuel pressure. I've seen also one bad tank of fuel ruin a fuel filter.

Mikes3500's Sig:2010crewcab, lb,4:10,line-x,mm,sinister egr/cooler delete, dpf/cat delete w/ stock muffler, 09HD ultra classic w/SE 103w/cams,69dz302 hugger orange.
Reply With Quote
  #8  
Old 03-12-2013, 08:37 PM
Newbie

   

Default

possibly you need the fuel rail shim kit or plug?

2011brokeblue6.7's Sig:2011 dode ram 2500 6.7, banks ram air,smarty s67 ME, mbrp 5" tbe, egr delete, gdp intake mainfold,gdp grid heater delete,ccv tube delete, airdogII 165,dunks traction bars, afe intercooler, 4" lift , 35" tires
Reply With Quote
  #9  
Old 04-22-2013, 04:53 PM
Newbie

   

Default

Any luck figuring out what the problem is? I seem to be having the same issue under hard acceleration. MADS says it is a software issue and we will have to wait for an update but I find it hard to believe that every 2012 with a JR is having this problem.
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 12:14 PM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check