Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Dodge Cummins > 5.9 Liter CR Dodge Cummins 03-07
Sign in using an external account
Register Forgot Password?
Search
Welcome to Diesel Bombers


Registered Members don't see these ads. Register now it's free!

5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-13-2010, 02:29 PM
TCdodge's Avatar
Diesel Fan

   
View Member's Albums

Default 2004 dodge ecm problems?

I have a 2004 dodge late model. Right after I bought it the TPS went bad so i replaced it and it fixed it for 2 months maybe. I have cleaned every ground I can find on dang thing also. After you drive the truck on a good drive (like 200 miles) it will go into limp mode and throw at least 12 codes. It throughs every code twice to for some stupid reason. They are like tps sensor, turbo, fuel rail pressure, camshaft position sensor, and so on. sometimes it throws up to 20 codes. the computer on the side of the motor had salvage writing on it so it has been replaced before i bought the truck so i though maybe it was bad. I found a used computer and bought it and put it on. It was a pull off computer that has a reconditoned sticker on it.(but it had been used after the recondition) Well it didnt fix the problem either. i didnt get the computer reprogrammed at the dealership or anything but everything worked. I was impressed. I dont know if its bad too or what but dodge wants 2 grand for a new one. But like i say it only does it after it gets good and hot. the truck does not have a chip or anything on it. And i dont believe it has ever had one. The manifold hasnt been tapped or anything. It has the fuel pump in the tank already. 160,000 miles. no white smoke or anything. It goes into limp mode when it does it though so its not a good deal. it sucks when your a couple of states away. sometimes it will die or just sit there and cut out really bad. but after you let it sit there a while it will start and run fine. I carry a scanner in it and sometimes it will delete the codes and fix it and other times it wont delete them. ive had a scanner at a dodge dealership on it and they didnt know anything more than me. i really dont know what do. Maybe a big cliff is in order. i would really appreciate any help. tyler.

TCdodge's Sig:97 power stroke pretty well stock but it will run a lot longer!
Reply With Quote
  #2  
Old 09-21-2010, 08:22 PM
wildbill's Avatar
BOMBARDIER
Status: Being Twisted In the Wind

   
View Member's Albums View Member's FaceBook Profile View Member's Youtube Account

Default

Have the dealer reprogram the other ECM with the options on your truck. Can't take an ECM off one and put it on another. Be cheaper than a new ECM, IF it works.

wildbill's Sig:
2006 Ram Cummins
"RAMPAGE"





Reply With Quote
  #3  
Old 12-17-2010, 01:34 PM
Newbie

   

Default

Originally Posted by TCdodge View Post
I have a 2004 dodge late model. Right after I bought it the TPS went bad so i replaced it and it fixed it for 2 months maybe. I have cleaned every ground I can find on dang thing also. After you drive the truck on a good drive (like 200 miles) it will go into limp mode and throw at least 12 codes. It throughs every code twice to for some stupid reason. They are like tps sensor, turbo, fuel rail pressure, camshaft position sensor, and so on. sometimes it throws up to 20 codes. the computer on the side of the motor had salvage writing on it so it has been replaced before i bought the truck so i though maybe it was bad. I found a used computer and bought it and put it on. It was a pull off computer that has a reconditoned sticker on it.(but it had been used after the recondition) Well it didnt fix the problem either. i didnt get the computer reprogrammed at the dealership or anything but everything worked. I was impressed. I dont know if its bad too or what but dodge wants 2 grand for a new one. But like i say it only does it after it gets good and hot. the truck does not have a chip or anything on it. And i dont believe it has ever had one. The manifold hasnt been tapped or anything. It has the fuel pump in the tank already. 160,000 miles. no white smoke or anything. It goes into limp mode when it does it though so its not a good deal. it sucks when your a couple of states away. sometimes it will die or just sit there and cut out really bad. but after you let it sit there a while it will start and run fine. I carry a scanner in it and sometimes it will delete the codes and fix it and other times it wont delete them. ive had a scanner at a dodge dealership on it and they didnt know anything more than me. i really dont know what do. Maybe a big cliff is in order. i would really appreciate any help. tyler.
Hello,
You cannot just put another unit in without programing it. Also the number has to match if not the will not work. I purchased mine here was programed and ready to go Auto Computer Exchange - Auto Computer Superstore - Cheaper than dealers and mechanics.
I talked to a guy name G he helped me out.

Hope this help
Reply With Quote
  #4  
Old 01-06-2011, 10:34 PM
TCdodge's Avatar
Diesel Fan

   
View Member's Albums

Default

thanks a million guys. it worked all but the windows wouldn't roll down and the ABS light was on. but it needed to be programmed. i put the old computer back on it now.
Reply With Quote
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 02:17 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check


1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233