Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Dodge Cummins > 5.9 Liter CR Dodge Cummins 03-07
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


I have a 2004 dodge late model. Right after I bought it the TPS went bad so i replaced it and it fixed it for 2 months maybe. I have cleaned every ground I can find on dang thing also. After you drive the truck ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-13-2010, 03:29 PM
TCdodge's Avatar
Diesel Fan

   
View Member's Albums

Default 2004 dodge ecm problems?

I have a 2004 dodge late model. Right after I bought it the TPS went bad so i replaced it and it fixed it for 2 months maybe. I have cleaned every ground I can find on dang thing also. After you drive the truck on a good drive (like 200 miles) it will go into limp mode and throw at least 12 codes. It throughs every code twice to for some stupid reason. They are like tps sensor, turbo, fuel rail pressure, camshaft position sensor, and so on. sometimes it throws up to 20 codes. the computer on the side of the motor had salvage writing on it so it has been replaced before i bought the truck so i though maybe it was bad. I found a used computer and bought it and put it on. It was a pull off computer that has a reconditoned sticker on it.(but it had been used after the recondition) Well it didnt fix the problem either. i didnt get the computer reprogrammed at the dealership or anything but everything worked. I was impressed. I dont know if its bad too or what but dodge wants 2 grand for a new one. But like i say it only does it after it gets good and hot. the truck does not have a chip or anything on it. And i dont believe it has ever had one. The manifold hasnt been tapped or anything. It has the fuel pump in the tank already. 160,000 miles. no white smoke or anything. It goes into limp mode when it does it though so its not a good deal. it sucks when your a couple of states away. sometimes it will die or just sit there and cut out really bad. but after you let it sit there a while it will start and run fine. I carry a scanner in it and sometimes it will delete the codes and fix it and other times it wont delete them. ive had a scanner at a dodge dealership on it and they didnt know anything more than me. i really dont know what do. Maybe a big cliff is in order. i would really appreciate any help. tyler.

TCdodge's Sig:97 power stroke pretty well stock but it will run a lot longer!
Reply With Quote
  #2  
Old 09-21-2010, 09:22 PM
wildbill's Avatar
BOMBARDIER
Status: Being Twisted In the Wind

   
View Member's Albums View Member's FaceBook Profile View Member's Youtube Account

Default

Have the dealer reprogram the other ECM with the options on your truck. Can't take an ECM off one and put it on another. Be cheaper than a new ECM, IF it works.

wildbill's Sig:
2006 Ram Cummins
"RAMPAGE"





Reply With Quote
  #3  
Old 12-17-2010, 02:34 PM
Newbie

   

Default

Originally Posted by TCdodge View Post
I have a 2004 dodge late model. Right after I bought it the TPS went bad so i replaced it and it fixed it for 2 months maybe. I have cleaned every ground I can find on dang thing also. After you drive the truck on a good drive (like 200 miles) it will go into limp mode and throw at least 12 codes. It throughs every code twice to for some stupid reason. They are like tps sensor, turbo, fuel rail pressure, camshaft position sensor, and so on. sometimes it throws up to 20 codes. the computer on the side of the motor had salvage writing on it so it has been replaced before i bought the truck so i though maybe it was bad. I found a used computer and bought it and put it on. It was a pull off computer that has a reconditoned sticker on it.(but it had been used after the recondition) Well it didnt fix the problem either. i didnt get the computer reprogrammed at the dealership or anything but everything worked. I was impressed. I dont know if its bad too or what but dodge wants 2 grand for a new one. But like i say it only does it after it gets good and hot. the truck does not have a chip or anything on it. And i dont believe it has ever had one. The manifold hasnt been tapped or anything. It has the fuel pump in the tank already. 160,000 miles. no white smoke or anything. It goes into limp mode when it does it though so its not a good deal. it sucks when your a couple of states away. sometimes it will die or just sit there and cut out really bad. but after you let it sit there a while it will start and run fine. I carry a scanner in it and sometimes it will delete the codes and fix it and other times it wont delete them. ive had a scanner at a dodge dealership on it and they didnt know anything more than me. i really dont know what do. Maybe a big cliff is in order. i would really appreciate any help. tyler.
Hello,
You cannot just put another unit in without programing it. Also the number has to match if not the will not work. I purchased mine here was programed and ready to go Auto Computer Exchange - Auto Computer Superstore - Cheaper than dealers and mechanics.
I talked to a guy name G he helped me out.

Hope this help
Reply With Quote
  #4  
Old 01-06-2011, 11:34 PM
TCdodge's Avatar
Diesel Fan

   
View Member's Albums

Default

thanks a million guys. it worked all but the windows wouldn't roll down and the ABS light was on. but it needed to be programmed. i put the old computer back on it now.
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 12:38 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check