Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Dodge Cummins > 5.9 Liter CR Dodge Cummins 03-07
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


I own a 2006 DODGE RAM 25000 with 5.9Liter Cummins Turbo with a 48RE tranny, the problem with this transmission is the following, no down shifting to 1st gear, when you take off from a stop it shift from 2nd gear to first gear back ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-22-2009, 06:45 AM
Newbie

   

Default Transmission Problems/// A618-48RE 2006

I own a 2006 DODGE RAM 25000 with 5.9Liter Cummins Turbo with a 48RE tranny, the problem with this transmission is the following, no down shifting to 1st gear, when you take off from a stop it shift from 2nd gear to first gear back and forward, to fix this problem do the following.

You need to replace
1. Transmission governor preasure selenoid # 4617210
2. Transmission governor sensor 2000 & newer, black plastic sensor # 56028196AD
3. Transmission overdrive & lock up selenoid 1998 on A618-48RE, this one comes with the harnes 8 cables and plug

USUALLY THE PROBLEM IS THE TRANSMISSION OVERDRIVE & LOCK UP SELENOID , BUT TO BE SURE I REPLACED ALL THE ELECTRONIC CONTROLS INSIDE THE TRANSMISSION ALSO I ADJUSTED THE FRONT BAND. YOU COULD BUY THIS PARTS ON LINE AT; TransmissionPartsUSA.com.........TEL. 239-790 5401. Im a Automotive Thecnitian Licence 11985, with 30 years expirience from PUERTO RICO .NEED MORE INFO CALL ME 787-469-5380
Reply With Quote
  #2  
Old 10-22-2009, 07:27 AM
Diesel Bomber

   
View Member's Albums

Default


You will get a better response to your question if you post it here:
5.9 Liter CR Dodge Cummins 03-07

mishkaya's Sig:'01 Dodge 6spd, Mach 7's, Helix 2 cam & springs, twins, Adrenaline, DD clutch, DOR bumper, etc...
Reply With Quote
  #3  
Old 05-11-2010, 02:38 AM
Newbie
Status: diesel

   
View Member's Albums View Member's FaceBook Profile

Default

I have a 2004 dodge with the 48RE trans i just took it in for hard shifting problems from first all the way to fourth was having extreme shifting thug. so they thought i needed the bands adjusted and the fluid changed so i did that.The problem went away for about a week or so but now it is back any ideas??? what should i do?
Reply With Quote
  #4  
Old 05-11-2010, 07:04 AM
dangerous1965's Avatar
Diesel Bomber
Status: After i got my License plate nobody wants to Play???

   
View Member's Albums

Default

Read the first post covers what you need!

dangerous1965's Sig:Goodies so far S&B intake,Silver bullet 64,AFE Stainless steel manifold, 90hp sticks, Head studs, 5" exhaust,SMARTY SSR,Airdog 150, 1/2" big Line kit,Gutted lift pump housing with draw straw Mod, T&C diesel CP-3,MP-8 at Half power, Custom intake with heater grid delete High Ram Intake, Built tranny, More guages than can be expected! 225 70r 19.5 tires at 80psi nitrous for laughs!
Reply With Quote
  #5  
Old 03-05-2012, 04:25 AM
Newbie

   
View Member's Albums

Default

So here's an issue... thought my starter drive wasn't engaging, could here it spinning, but not cranking the engine... had 20 min to make it to auto zone to get a starter if that was the problem... got underneath the thing to find that the starter was physically loose, I mean the top bolt missing the bottom two backed out, one barely hanging on! figuring that the problem was the physical interface, and missing one bolt, we didn't see the need to remove and replace a working part, instead tighten the bolts back down and replace the missing bolt the next day... Well, that worked, but when tightening the battery leads the truck turned off... when we attempted to restart, the housing around the lower bolt cracked and back to the existing problem... The decision was made to place the lower bolt in place of the upper, limp home, and install new starter the next day... Here's were it gets interesting... The upper bolt is in a hard to reach location using a 10mm and a ratchet, my friend accidently drops the ratchet and best we could tell it hits the lead, and arcs... Everyone's okay... Finally get it tightened, truck starts...

So, why am I in a tranny post talking about the starter... it's called foreshadowing I suppose...

On my drive home I didn't notice anything wrong until about half a mile from the house, the truck seemed like it wasn't shifting right... I slowed, and put it in neutral... then back to drive... I was making the speed limit of 25, but then started to loose power... completely! I was stuck rev'ing the engine 100 yards from my driveway on the side of the road, reverse wasn't working, and neither was drive... Finally it started moving, but not the way it should, there was just no "take off", and when it tried shifting it just started jerking... kinda like a limited slip engaging and disengaging in sand... Got it parked, and tried moving it, but when it is put in gear it doesn't roll at idle in drive or reverse... if I get it up to around 1500 RPM it'll slowly respond, but not with much force, barely with the power you'd get at idle...

best I can guess is that that spark shorted something out in the transmission... but I have no idea where to start... could be the frustration that this just happened, but I'm in the dark right now... guys/gals, does anyone out there have an idea of what is going on? I deploy in a couple of months, and need my only vehicle to get to and from work, can't rely on rides from coworkers all the time!

06 CTD 4WD... no codes... stock 48re... 4WD still engages fine... thanks in advance

---AutoMerged DoublePost---

update... ran outside last night to grab my uniform from the truck... noticed tranny fluid everywhere... not sure of source, but foward drive shaft coated, as well as the pan... it's a mess, looks as if someone slit a throat next to my truck!

inksmith's Sig:2006 Ram 2500 MegaCab 4WD 5.9L CTD Auto... 6" SuperLift, 37x13x17 Toyo MT's, 17" Teflon coated American Racing Mojave's, Exhaust Deleted, AFE Stage 2 intake, AFE Intake Manifold, Bully Dog PMT

Last edited by inksmith; 03-05-2012 at 04:25 AM.. Reason: Automerged Doublepost
Reply With Quote
  #6  
Old 03-05-2012, 10:50 AM
Newbie

   

Default

i kinda have the same problem but there was no arc that caused mine. trans just wont go into gear.
Reply With Quote
  #7  
Old 10-28-2012, 01:34 AM
Newbie

   

Default

Did you figure out whats wrong? I have the same problem and have no lue how to fix it. i also have a manual.












Originally Posted by inksmith View Post
So here's an issue... thought my starter drive wasn't engaging, could here it spinning, but not cranking the engine... had 20 min to make it to auto zone to get a starter if that was the problem... got underneath the thing to find that the starter was physically loose, I mean the top bolt missing the bottom two backed out, one barely hanging on! figuring that the problem was the physical interface, and missing one bolt, we didn't see the need to remove and replace a working part, instead tighten the bolts back down and replace the missing bolt the next day... Well, that worked, but when tightening the battery leads the truck turned off... when we attempted to restart, the housing around the lower bolt cracked and back to the existing problem... The decision was made to place the lower bolt in place of the upper, limp home, and install new starter the next day... Here's were it gets interesting... The upper bolt is in a hard to reach location using a 10mm and a ratchet, my friend accidently drops the ratchet and best we could tell it hits the lead, and arcs... Everyone's okay... Finally get it tightened, truck starts...

So, why am I in a tranny post talking about the starter... it's called foreshadowing I suppose...

On my drive home I didn't notice anything wrong until about half a mile from the house, the truck seemed like it wasn't shifting right... I slowed, and put it in neutral... then back to drive... I was making the speed limit of 25, but then started to loose power... completely! I was stuck rev'ing the engine 100 yards from my driveway on the side of the road, reverse wasn't working, and neither was drive... Finally it started moving, but not the way it should, there was just no "take off", and when it tried shifting it just started jerking... kinda like a limited slip engaging and disengaging in sand... Got it parked, and tried moving it, but when it is put in gear it doesn't roll at idle in drive or reverse... if I get it up to around 1500 RPM it'll slowly respond, but not with much force, barely with the power you'd get at idle...

best I can guess is that that spark shorted something out in the transmission... but I have no idea where to start... could be the frustration that this just happened, but I'm in the dark right now... guys/gals, does anyone out there have an idea of what is going on? I deploy in a couple of months, and need my only vehicle to get to and from work, can't rely on rides from coworkers all the time!

06 CTD 4WD... no codes... stock 48re... 4WD still engages fine... thanks in advance

---AutoMerged DoublePost---

update... ran outside last night to grab my uniform from the truck... noticed tranny fluid everywhere... not sure of source, but foward drive shaft coated, as well as the pan... it's a mess, looks as if someone slit a throat next to my truck!
Reply With Quote
  #8  
Old 01-07-2013, 10:08 PM
Newbie

   

Default shifting problems

Originally Posted by ruben o. Garcia View Post
I own a 2006 DODGE RAM 25000 with 5.9Liter Cummins Turbo with a 48RE tranny, the problem with this transmission is the following, no down shifting to 1st gear, when you take off from a stop it shift from 2nd gear to first gear back and forward, to fix this problem do the following.

You need to replace
1. Transmission governor preasure selenoid # 4617210
2. Transmission governor sensor 2000 & newer, black plastic sensor # 56028196AD
3. Transmission overdrive & lock up selenoid 1998 on A618-48RE, this one comes with the harnes 8 cables and plug

USUALLY THE PROBLEM IS THE TRANSMISSION OVERDRIVE & LOCK UP SELENOID , BUT TO BE SURE I REPLACED ALL THE ELECTRONIC CONTROLS INSIDE THE TRANSMISSION ALSO I ADJUSTED THE FRONT BAND. YOU COULD BUY THIS PARTS ON LINE AT; TransmissionPartsUSA.com.........TEL. 239-790 5401. Im a Automotive Thecnitian Licence 11985, with 30 years expirience from PUERTO RICO .NEED MORE INFO CALL ME 787-469-5380
Can I do this with out pulling the tranny completely out I pulled my pan and changed the filter and fluid had a little black stuff in the bottom of the pan but no metal or anything like that I added lucas and new filter but its still having the same problem my tranny is doing the same thing as described here there is 243000 miles on the truck with no up grades other than takeing my cat out its a 2006 mage cab dulley 4x4 thanks Alex
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


LinkBacks (?)
LinkBack to this Thread: http://www.dieselbombers.com/5-9-liter-cr-dodge-cummins-03-07/34751-transmission-problems-a618-48re-2006-a.html
Posted By For Type Date
Engine Performance Parts Manufactures - Diesel Bookmarks - Diesel Related Links Directory This thread Refback 10-22-2009 12:19 PM

 
All times are GMT -5. The time now is 12:15 PM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check