Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Dodge Cummins > 5.9 Liter CR Dodge Cummins 03-07
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


I have an 07 5.9 cummins and when I am into the throttle the engines cuts on and off like someone is flicking a switch. it starts around 2500 to 3000 rpms. I changed the fuel filter and no difference? Thanks for any help on ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-31-2009, 10:28 AM
Diesel Fan

   
View Member's FaceBook Profile

Default 07 5.9 Engine Cuts out at higher rpms

I have an 07 5.9 cummins and when I am into the throttle the engines cuts on and off like someone is flicking a switch. it starts around 2500 to 3000 rpms. I changed the fuel filter and no difference? Thanks for any help on this.

RINEHOLT98's Sig:2007 5.9l Cummins 3500 Megacab DRW Straight Pipe, AFE Intake, Airdog, 6 Speed
Reply With Quote
  #2  
Old 08-31-2009, 01:48 PM
Diesel Fan

   

Default

do you have a fuel pressure gauge? could be the lift pump..maybe rail pressure drop too
Reply With Quote
  #3  
Old 08-31-2009, 06:39 PM
Diesel Fan

   
View Member's FaceBook Profile

Default

No, I dont have a gauge. I went to start it today and the engine died like it was running out of fuel. I got these codes P0513-invalid key shim, p0234 - Turbocharger overboost, p2509 ECM/PCM Power input signal intermittent, and p0251 - injection pump fuel valve feedback. Got no clue what is going on now.
Reply With Quote
  #4  
Old 08-31-2009, 06:45 PM
wildbill's Avatar
BOMBARDIER
Status: Being Twisted In the Wind

   
View Member's Albums View Member's FaceBook Profile View Member's Youtube Account

Default

P0251 is related to the FCA (fuel control actuator). It's mounted on the back of the CP3 with 3 small screws. A new one from Cummins is about $120-$150.

wildbill's Sig:
2006 Ram Cummins
"RAMPAGE"





Reply With Quote
  #5  
Old 09-01-2009, 11:04 AM
Diesel Fan

   
View Member's FaceBook Profile

Default

Figured out that the key fob has a microchip in it. I used a copied key and after you start the truck it senses no microchip and kills the engine. The truck still cuts out when I am getting on the throttle though. I will look at the FCA. Thanks Wildbill!
Reply With Quote
  #6  
Old 09-07-2009, 08:45 PM
cummin_un_glued's Avatar
Supporting Vendor
Status: Torque Diesel LLC

   
Send a message via AIM to cummin_un_glued Send a message via Yahoo to cummin_un_glued

Default

i'm really interested in what you find out my 07 5.9 just started doing the exact same thing on the way home from terre haute except i have no codes and i just replaced the injectors today and that did not fix it

cummin_un_glued's Sig:11 6.7 4500 H&S treatment
06 5.9 EFI Live tuned MegaTon
01 5.9 13mm p-pump'd Super Street 11.34 @ 117
2010 Mo-Ark truck pullers 2.6 and 2.8 class points champion

Dustin @

870-710-3850
Reply With Quote
  #7  
Old 09-08-2009, 06:30 PM
Newbie

   

Default

My 03 is doing it too, but it's doing it around 2000 rpm with the Edge Juice w/A on any setting.

Previous owner had the in-tank lift pump retrofit, but no idea on the mileage on it.
I have a BD Flow-Max on order, and hope to have it in hand this week.

I'll keep you posted.
Reply With Quote
  #8  
Old 05-16-2011, 08:09 PM
hydroshok's Avatar
Diesel Enthusiast
Status: My money maker shakes itself...

   
View Member's Albums View Member's FaceBook Profile View Member's Twitter Account

Default

I had this happen to me but all the lights came on like I was trying to start the truck. I have read where it has happened like you are saying. I turned the key on for 10min then off for 10min the back on for 10min and that seemed to work for a while. The stealership offered to reprogram my keys for free after that so I don't know if that will really fix it, but worth a try. It is a simple fix. I had no codes for a long time then the skim key code was present. Let me know if you try it...

hydroshok's Sig:
89 cummins/83 crew cab 5spd 2wd: P-pump 24v, 10 spd roadranger, 05 E-450 rear, push button start, pull cable and gauges
01 2500 4x4 5spd: 12 valve swap, 4kgsk, 19*, AFE intake, AirDog, HX40, air ride, exhaust brake and gauges
**If you run bio-diesel; do you roll coleslaw?**
Reply With Quote
 
 
 
submit to reddit
Reply


« NEED HELP? | EGT's »
Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 04:56 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check