Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Dodge Cummins > 5.9 Liter CR Dodge Cummins 03-07
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!


5.9 Liter CR Dodge Cummins 03-07 Discussion of 5.9 Liter Dodge Cummins Diesels with Common Rail Injection

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


i have an 06 dodge cummins with the edge in it. i have 2 dtcs coming up, p2121 and p2127 both related to the apps sensor. i have replaced the sensor and had the dealer reflash the computer. im still having the same codes come ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-06-2008, 10:05 AM
haring164's Avatar
Diesel Fan

   
View Member's Albums

Default DTC P2121 And P2127

i have an 06 dodge cummins with the edge in it. i have 2 dtcs coming up, p2121 and p2127 both related to the apps sensor. i have replaced the sensor and had the dealer reflash the computer. im still having the same codes come up. ive cleared the dtcs and removed the edge chip but im still having the same problems. its causing the throttle to shut off for 3-4 seconds between 40-50 mphs while accelerating. the dealer had no idea what could still be causing it. anyone have any ideas?
Reply With Quote
  #2  
Old 08-25-2008, 09:51 PM
2001shrtbedcummins's Avatar
Diesel Bomber
Status: bored

   
Default

Have you tried checking the voltage on the APPS?

2001shrtbedcummins's Sig:Mexican Baseball League "I love this game"
Man who marries girl with no bust has right to feel down low.

Reply With Quote
  #3  
Old 08-25-2008, 09:54 PM
FormerVendor
Status: My Customers are #1

Luke Buchanan lukesdiesel
   
Default

P2121 - Accelerator Pedal Position Sensor Circuit 1 Range/Performance.

P2127 - Accelerator Pedal Position Sensor Circuit 2 Low Input.

Bad APPS, Short in APPS or possibly bad PCM
Reply With Quote
  #4  
Old 12-31-2008, 08:35 AM
Newbie

   

Default

What was the problem? I have similar issues.
Reply With Quote
  #5  
Old 06-01-2009, 06:50 PM
Newbie

   

Default I have same problem please help

Originally Posted by haring164 View Post
i have an 06 dodge cummins with the edge in it. i have 2 dtcs coming up, p2121 and p2127 both related to the apps sensor. i have replaced the sensor and had the dealer reflash the computer. im still having the same codes come up. ive cleared the dtcs and removed the edge chip but im still having the same problems. its causing the throttle to shut off for 3-4 seconds between 40-50 mphs while accelerating. the dealer had no idea what could still be causing it. anyone have any ideas?

I have same problem what should I do?


please help.......
Reply With Quote
  #6  
Old 06-01-2009, 08:01 PM
thebreeze04's Avatar
Diesel Enthusiast
Status: Hardly Working

   
Default

If the PCM is causing your problems a reflash will not fix it a new PCM from the dealer is the only thing that will seen this several times at our shop and we always send it out.

thebreeze04's Sig:2004.5 Cummins 600, Edge Juice, Straight Pipe, HTS Transmission, 2" leveling kit,whats a silencer ring? AIRAID JR, swiss air box 315/70R17Dune Grapplers
Reply With Quote
  #7  
Old 12-20-2009, 06:12 AM
haring164's Avatar
Diesel Fan

   
View Member's Albums

Default

does anyone have any updates on this issue. the problem is only occuring when its raining out or snowing. im starting to think that it is a connection problem under the hood and moisture is getting into a connection somewhere. i recently read that it could be the connectiion on the top of the cp3 pump. Is there any other connections that i may need to pay closer attention to to see if it may be coming from somewhere else?
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 11:25 PM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check