Diesel Bombers SIGN UP NOW

National Association of Diesel Motorsports
Go Back   Diesel Bombers > Dodge Cummins > 12 Valve 2nd Gen Dodge Cummins 94-98
Sign in using an external account
Register Forgot Password?
Search


Registered Members don't see these ads. Register now it's free!

12 Valve 2nd Gen Dodge Cummins 94-98 Discussion of 12 Valve 5.9 Liter Dodge Cummins Diesels with P7100 Injection Pumps

Welcome to Diesel Bombers Forums!
Welcome to DieselBombers .com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the Diesel Bombers Forums community today!


has anyone installed a over amp'd alternator in there truck? my plow truck seems to be killing battery every storm i dont think the stock 130 amp alt. is working good enought id like to get somehting that will produce more juice... between all the ... JOIN NOW TO REMOVE TRACER

Reply
 
 
 
submit to reddit
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-22-2013, 05:27 PM
gyayo2012's Avatar
Diesel Enthusiast
Status: Rollin coal

   
View Member's Albums View Member's Youtube Account

Default power up alt..

has anyone installed a over amp'd alternator in there truck? my plow truck seems to be killing battery every storm i dont think the stock 130 amp alt. is working good enought id like to get somehting that will produce more juice... between all the lights strobes and plow going up and down its not doing to good... anyone buy a over ampd alt or know how to make it get more power or replace it with a diff model alt.?? any info would be great thanks a guys!!

gyayo2012's Sig:96 auto, bhaf, 4" t-back, #6 plate, 3k gsk! Boost elbo, Boost,Egt,Transtemp guages, Bilstein5100's, 98 hd t style steering,rear dana 70 disk conversion!

95 dump 4x4 auto 410s pretty much stock... has a 160 pump put a 180 plate in and slid it ff. bhaf 3" strait piped
Reply With Quote
  #2  
Old 01-26-2013, 02:40 PM
Red_Rattler's Avatar
High Tech Redneck
Status: Agent ORANGE

Jacob Boness
   
Default

How good are the batts first thing second is it the original alt? Also stock they are 140 amps. But I've never heard of the company you mentioned nor could I find a website. But you def have another issue than the stock one cant keep up.

Red_Rattler's Sig:JAKE


DIESEL BOMBERS SUPER MODERATOR

CLICK HERE FOR SPONSORSHIP INFORMATION
CLICK HERE TO BECOME A PREMIUM MEMBER AKA BOMBARDIER
_________________________________________
03Flame Red 2500 4x4 QuadCab Handshaker HO,Kore HP Kit, Smarty REVO, AIRDOG II 165, Banks TechniCooler, K&N FIPK, MBRP Cool Duals 6inch tips, GunSlinger Pistol Grip Shifter, SRT Inine 6 Hood, Jacobs Brake

95 2500 4X4 Ext Cab Handshaker "BUCKN' BADGER"
Reply With Quote
  #3  
Old 01-27-2013, 03:51 PM
gyayo2012's Avatar
Diesel Enthusiast
Status: Rollin coal

   
View Member's Albums View Member's Youtube Account

Default

140 from a stock unit? im guessing its a stock setup in the truck i've never replaced it everyone ive talked to had said the stock alt. runs at 130, autozone said they have a 120, i have a local guy that said he can build be one that will put out 136.... id be totaly happy with a 140 amp alt.. i put new remans intrstate batt. in right before winter hit 2 1000 cca they drain almost instantly if im running all the lights and plow a couple times up and down then my batt. power is at 8.. also when i fist start the tuck, the bottery power will surge also my heat and lights will go with it.. but after it warm up for a bit it goes back to normal..

---AutoMerged DoublePost---

do you have any recomendations as to what kind of alternator to purchace for a resonable price?..

Last edited by gyayo2012; 01-27-2013 at 03:51 PM.. Reason: Automerged Doublepost
Reply With Quote
  #4  
Old 02-05-2013, 08:59 PM
Diesel Fan
Status: shooting for world class GM mastertech by next year

   

Default

i hope i understand you correctly , im going to assume the engine is running when you are stating the batterys are going dead

there is another problem somewhere, plows do draw pretty hard but unless you have stadium lights on your truck you shouldnt be pulling down 2 healthy 1000cca batterys
within a few cyclings of the plow hyd pump

batterys are pretty much a sponge , they store excess potential energy and provive it in times where the alternator cannot keep up, wich doenst last for very long,12v deisel engines require a very small ammount of current so there is a issue somewhere else if your batterys are dropping out so fast

the fluctuations in your voltmeter at start up is your intake heater grid cycling and is a normal condition,

your maxi fuse in the PDC assuming it is still stock is only 120A so pulling more than that will lead to more issues than dead batterys

i would check the field driver circuit k20 i think 18gg DG wire for resistance , from the pcm to the generator for resistance value, anything over 1 olm is pointing to a issue and all the battery grounds are prone to corrosion wich is often overlooked

good luck

scot
Reply With Quote
  #5  
Old 02-06-2013, 04:31 PM
gyayo2012's Avatar
Diesel Enthusiast
Status: Rollin coal

   
View Member's Albums View Member's Youtube Account

Default

i was out side testing today have to get ready for th big storm were supose to get on fri into sat.. the battery are holding up good when truck off they are fill 12.7 but i found that the alt is only reading 13v and my baterys after start up read the same 13/13.5 my other truck reads 14.5 at alt. and the batery when started.. does this mean the alt. is crapin out on me im guessing thats why the baterys cant keep up when i have lights strobes and running plow!!? any ideas only have a couple days to get this thing done other wise its going to make for a l0ng NIGHT!!

---AutoMerged DoublePost---

i also forgot to mention that the volts go up when im driving but as soon as i let off they drop again its goes with the rpms. any help would be great thanks!!.

---AutoMerged DoublePost---

update again.. i ebeded up pulling off the alt. and the whole bottom half of it was broken off could barley spin it by hand either so it was deff the problem went bought a brand new one and installd everything works great!!

Last edited by gyayo2012; 02-06-2013 at 04:31 PM.. Reason: Automerged Doublepost
Reply With Quote
 
 
 
submit to reddit
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


 
All times are GMT -5. The time now is 08:47 AM.

Copyright And Legal Notice Links Of Interest

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Diesel Bombers ® - All Content Protected Under Intellectual Property Rights Law of Registered Trademarks
Reg. No. 3,494,401 Cls. 100, 101 & 104 Under Int. Cl. 38
USE AT YOUR OWN RISK WE HOLD NO LIABILITY FOR ANY CONTENT RIGHT, WRONG OR INDIFFERENT

Protected by Copyscape Duplicate Content Check